Upgrade to Bullseye

Set in Plynth such that the upgrade should run to bullseye, but I get this error message in var/log/unattended-upgrades…:

dpkg: unrecoverable fatal error, aborting:
loading files list file for package ‘python-django-common’: cannot read /var/lib/dpkg/info/python-django-common.list (Input/output error)
Error: Timeout was reached
Snapshot ‘11533’ not found.

The log in Plinth says
“2021-08-16 06:35:12,010 ERROR Installing the upgrades failed!
2021-08-16 06:35:12,309 ERROR error message: installArchives() failed
2021-08-16 06:35:12,326 ERROR dpkg returned a error! See /var/log/unattended-upgrades/unattended-upgrades-dpkg.log for details”
and it is full of “2021-08-16 06:29:42,810 WARNING package xxx upgradable but fails to be marked for upgrade ()”

Do I have to run the upgrade from consol?

By the way: Cockpit gives an internal server error

EDIT:
$ ls -l python-django-common.list
-rw-r–r-- 1 root root 358350 Jun 19 2020 python-django-common.list

EDIT2:
$ cat python-django-common.list
returns an i/O error:
“/usr/share/python-django-common/django/contrib/flatpages/locale/ga/LC_MESSAGES/django.po
/usr/share/python-django-commoncat: python-django-common.list: Eingabe-/Ausgabefehler”

but “tail” works
however if I read through it with “nano”, it breaks at the same point.
Something is broken in that file, maybe some “bad” character?
We need a good version of this file.

The upgrade doesn’t work for me neither !

2021-08-16 17:38:32,455 WARNING package libpython2.7 upgradable but fails to be marked for upgrade (E:Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.)
2021-08-16 17:38:38,018 WARNING package libpython2.7-minimal upgradable but fails to be marked for upgrade (E:Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.)
2021-08-16 17:38:42,869 WARNING package libpython2.7-stdlib upgradable but fails to be marked for upgrade (E:Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.)
2021-08-16 17:38:51,417 WARNING package libpython3-stdlib upgradable but fails to be marked for upgrade (E:Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.)
2021-08-16 17:38:57,798 WARNING package libref-util-xs-perl upgradable but fails to be marked for upgrade (E:Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.)
2021-08-16 17:39:03,260 WARNING package librpc-xml-perl upgradable but fails to be marked for upgrade (E:Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.)
2021-08-16 17:39:08,392 WARNING package libscalar-string-perl upgradable but fails to be marked for upgrade (E:Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.)
2021-08-16 17:39:14,038 WARNING package libsearch-xapian-perl upgradable but fails to be marked for upgrade (E:Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.)
2021-08-16 17:39:18,969 WARNING package libslang2 upgradable but fails to be marked for upgrade ()
2021-08-16 17:39:24,315 WARNING package libspecio-perl upgradable but fails to be marked for upgrade (E:Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.)
2021-08-16 17:39:28,945 WARNING package libsqlite3-0 upgradable but fails to be marked for upgrade ()
2021-08-16 17:39:34,202 WARNING package libstdc++6 upgradable but fails to be marked for upgrade ()
2021-08-16 17:39:39,795 WARNING package libsub-identify-perl upgradable but fails to be marked for upgrade (E:Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.)
2021-08-16 17:39:45,814 WARNING package libsub-name-perl upgradable but fails to be marked for upgrade (E:Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.)
2021-08-16 17:39:50,130 WARNING package libsystemd0 upgradable but fails to be marked for upgrade ()
2021-08-16 17:39:55,606 WARNING package libtdb1 upgradable but fails to be marked for upgrade (E:Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.)
2021-08-16 17:40:01,653 WARNING package libterm-readkey-perl upgradable but fails to be marked for upgrade (E:Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.)
2021-08-16 17:40:06,825 WARNING package libterm-readline-gnu-perl upgradable but fails to be marked for upgrade (E:Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.)
2021-08-16 17:40:11,096 WARNING package libtext-charwidth-perl upgradable but fails to be marked for upgrade (E:Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.)
2021-08-16 17:40:16,866 WARNING package libtext-iconv-perl upgradable but fails to be marked for upgrade (E:Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.)
2021-08-16 17:40:23,655 WARNING package libtext-markdown-discount-perl upgradable but fails to be marked for upgrade (E:Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.)
2021-08-16 17:40:30,343 WARNING package libtiff5 upgradable but fails to be marked for upgrade ()
2021-08-16 17:40:35,793 WARNING package libudev1 upgradable but fails to be marked for upgrade ()
2021-08-16 17:40:41,203 WARNING package libvariable-magic-perl upgradable but fails to be marked for upgrade (E:Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.)
2021-08-16 17:40:46,885 WARNING package libwbclient0 upgradable but fails to be marked for upgrade (E:Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.)
2021-08-16 17:40:53,746 WARNING package libwebp6 upgradable but fails to be marked for upgrade ()
2021-08-16 17:40:59,830 WARNING package libwebpmux3 upgradable but fails to be marked for upgrade ()
2021-08-16 17:41:06,277 WARNING package libxapian30 upgradable but fails to be marked for upgrade ()
2021-08-16 17:41:11,305 WARNING package libxml-libxml-perl upgradable but fails to be marked for upgrade (E:Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.)
2021-08-16 17:41:16,210 WARNING package libxml-parser-perl upgradable but fails to be marked for upgrade (E:Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.)
2021-08-16 17:41:22,935 WARNING package libxml2 upgradable but fails to be marked for upgrade ()
2021-08-16 17:41:28,617 WARNING package libxslt1.1 upgradable but fails to be marked for upgrade ()
2021-08-16 17:41:34,667 WARNING package libxtables12 upgradable but fails to be marked for upgrade (E:Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.)
2021-08-16 17:41:39,571 WARNING package libyaml-libyaml-perl upgradable but fails to be marked for upgrade (E:Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.)
2021-08-16 17:41:45,740 WARNING package libzmq5 upgradable but fails to be marked for upgrade ()
2021-08-16 17:41:50,991 WARNING package mailutils upgradable but fails to be marked for upgrade ()
2021-08-16 17:41:56,170 WARNING package mailutils-common upgradable but fails to be marked for upgrade ()
2021-08-16 17:42:00,753 WARNING package mawk upgradable but fails to be marked for upgrade ()
2021-08-16 17:42:09,872 WARNING package network-manager upgradable but fails to be marked for upgrade (E:Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.)
2021-08-16 17:42:16,211 WARNING package nscd upgradable but fails to be marked for upgrade ()
2021-08-16 17:42:22,346 WARNING package openjdk-11-jre-headless upgradable but fails to be marked for upgrade ()
2021-08-16 17:42:29,613 WARNING package packagekit upgradable but fails to be marked for upgrade ()
2021-08-16 17:42:37,116 WARNING package packagekit-tools upgradable but fails to be marked for upgrade ()
2021-08-16 17:42:43,942 WARNING package pcp upgradable but fails to be marked for upgrade (E:Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.)
2021-08-16 17:42:51,313 WARNING package pcp-conf upgradable but fails to be marked for upgrade (E:Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.)
2021-08-16 17:43:04,369 WARNING package perl-base upgradable but fails to be marked for upgrade (E:Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.)
2021-08-16 17:43:12,160 WARNING package php-common upgradable but fails to be marked for upgrade (E:Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.)
2021-08-16 17:43:17,647 WARNING package php-fpm upgradable but fails to be marked for upgrade ()
2021-08-16 17:43:22,986 WARNING package policykit-1 upgradable but fails to be marked for upgrade ()
2021-08-16 17:43:28,273 WARNING package ppp upgradable but fails to be marked for upgrade (E:Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.)
2021-08-16 17:43:33,676 WARNING package python2 upgradable but fails to be marked for upgrade (E:Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.)
2021-08-16 17:43:40,527 WARNING package python2-minimal upgradable but fails to be marked for upgrade (E:Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.)
2021-08-16 17:43:50,175 WARNING package python2.7 upgradable but fails to be marked for upgrade (E:Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.)
2021-08-16 17:43:55,772 WARNING package python2.7-minimal upgradable but fails to be marked for upgrade (E:Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.)
2021-08-16 17:44:03,378 WARNING package python3 upgradable but fails to be marked for upgrade (E:Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.)
2021-08-16 17:44:11,490 WARNING package python3-apt upgradable but fails to be marked for upgrade (E:Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.)
2021-08-16 17:44:17,225 WARNING package python3-cffi-backend upgradable but fails to be marked for upgrade (E:Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.)
2021-08-16 17:44:24,087 WARNING package python3-dbus upgradable but fails to be marked for upgrade (E:Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.)
2021-08-16 17:44:30,780 WARNING package python3-distutils upgradable but fails to be marked for upgrade (E:Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.)
2021-08-16 17:44:34,523 WARNING package python3-django upgradable but fails to be marked for upgrade ()
2021-08-16 17:44:40,819 WARNING package python3-gi upgradable but fails to be marked for upgrade (E:Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.)
2021-08-16 17:44:47,453 WARNING package python3-jsonschema upgradable but fails to be marked for upgrade (E:Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.)
2021-08-16 17:44:55,099 WARNING package python3-lib2to3 upgradable but fails to be marked for upgrade (E:Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.)
2021-08-16 17:45:00,638 WARNING package python3-llfuse upgradable but fails to be marked for upgrade (E:Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.)
2021-08-16 17:45:06,855 WARNING package python3-lxml upgradable but fails to be marked for upgrade (E:Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.)
2021-08-16 17:45:12,463 WARNING package python3-markupsafe upgradable but fails to be marked for upgrade (E:Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.)
2021-08-16 17:45:19,546 WARNING package python3-minimal upgradable but fails to be marked for upgrade (E:Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.)
2021-08-16 17:45:25,261 WARNING package python3-msgpack upgradable but fails to be marked for upgrade (E:Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.)
2021-08-16 17:45:33,097 WARNING package python3-parsedatetime upgradable but fails to be marked for upgrade (E:Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.)
2021-08-16 17:45:40,442 WARNING package python3-pcp upgradable but fails to be marked for upgrade (E:Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.)
2021-08-16 17:45:46,421 WARNING package python3-pil upgradable but fails to be marked for upgrade (E:Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.)
2021-08-16 17:45:53,715 WARNING package python3-psutil upgradable but fails to be marked for upgrade (E:Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.)
2021-08-16 17:45:59,962 WARNING package python3-psycopg2 upgradable but fails to be marked for upgrade (E:Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.)
2021-08-16 17:46:08,078 WARNING package python3-ruamel.yaml upgradable but fails to be marked for upgrade (E:Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.)
2021-08-16 17:46:15,774 WARNING package python3-selinux upgradable but fails to be marked for upgrade (E:Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.)
2021-08-16 17:46:23,242 WARNING package python3-simplejson upgradable but fails to be marked for upgrade (E:Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.)
2021-08-16 17:46:29,237 WARNING package python3-six upgradable but fails to be marked for upgrade (E:Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.)
2021-08-16 17:46:36,132 WARNING package python3-systemd upgradable but fails to be marked for upgrade (E:Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.)
2021-08-16 17:46:42,042 WARNING package python3-twisted upgradable but fails to be marked for upgrade (E:Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.)
2021-08-16 17:46:48,401 WARNING package python3-twisted-bin upgradable but fails to be marked for upgrade (E:Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.)
2021-08-16 17:46:53,723 WARNING package python3-yaml upgradable but fails to be marked for upgrade (E:Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.)
2021-08-16 17:47:00,837 WARNING package python3-zope.hookable upgradable but fails to be marked for upgrade (E:Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.)
2021-08-16 17:47:08,325 WARNING package python3-zope.interface upgradable but fails to be marked for upgrade (E:Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.)
2021-08-16 17:47:14,083 WARNING package rsyslog upgradable but fails to be marked for upgrade ()
2021-08-16 17:47:21,739 WARNING package samba-common upgradable but fails to be marked for upgrade (E:Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.)
2021-08-16 17:47:28,720 WARNING package samba-common-bin upgradable but fails to be marked for upgrade (E:Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.)
2021-08-16 17:47:34,812 WARNING package samba-dsdb-modules upgradable but fails to be marked for upgrade (E:Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.)
2021-08-16 17:47:41,080 WARNING package samba-libs upgradable but fails to be marked for upgrade (E:Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.)
2021-08-16 17:47:47,098 WARNING package service-wrapper upgradable but fails to be marked for upgrade ()
2021-08-16 17:47:55,055 WARNING package shadowsocks-libev upgradable but fails to be marked for upgrade ()
2021-08-16 17:48:03,710 WARNING package slapd upgradable but fails to be marked for upgrade (E:Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.)
2021-08-16 17:48:12,987 WARNING package snapper upgradable but fails to be marked for upgrade ()
2021-08-16 17:48:23,250 WARNING package systemd upgradable but fails to be marked for upgrade ()
2021-08-16 17:48:30,069 WARNING package systemd-container upgradable but fails to be marked for upgrade ()
2021-08-16 17:48:37,519 WARNING package tor upgradable but fails to be marked for upgrade ()
2021-08-16 17:48:43,087 WARNING package tor-geoipdb upgradable but fails to be marked for upgrade ()
2021-08-16 17:48:50,831 WARNING package udev upgradable but fails to be marked for upgrade ()
2021-08-16 17:48:58,526 WARNING package unattended-upgrades upgradable but fails to be marked for upgrade (E:Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.)
2021-08-16 17:49:04,299 WARNING package uwsgi upgradable but fails to be marked for upgrade ()
2021-08-16 17:49:12,650 WARNING package uwsgi-core upgradable but fails to be marked for upgrade ()
2021-08-16 17:49:18,771 WARNING package uwsgi-plugin-python3 upgradable but fails to be marked for upgrade ()
2021-08-16 17:49:25,203 WARNING package wpasupplicant upgradable but fails to be marked for upgrade ()
2021-08-16 17:49:30,674 WARNING package xapian-omega upgradable but fails to be marked for upgrade ()
2021-08-16 17:49:44,367 WARNING Package media-types has conffile prompt and needs to be upgraded manually
2021-08-16 17:49:44,372 ERROR failed to read deb file media-types (E:Could not open file media-types - open (2: No such file or directory))
2021-08-16 17:49:46,163 INFO package mime-support not upgraded
2021-08-16 17:49:48,135 INFO Packages that will be upgraded:
2021-08-16 17:49:51,918 WARNING Found /var/run/reboot-required, rebooting
2021-08-16 17:49:51,983 WARNING Shutdown msg: b"Shutdown scheduled for Tue 2021-08-17 02:00:00 CEST, use ‘shutdown -c’ to cancel."

Similar problem.

First, a number of “package upgradable but fails to be marked for upgrade”.

2021-08-15 06:20:05,411 INFO Allowed origins are: origin=Debian,codename=bullseye,label=Debian, origin=Debian,codename=bullseye,
label=Debian-Security, o=Debian Backports,a=bullseye-backports,l=Debian Backports
2021-08-15 06:20:16,236 WARNING package apache2-bin upgradable but fails to be marked for upgrade (E:Error, pkgProblemResolver::
Resolve generated breaks, this may be caused by held packages.)
2021-08-15 06:20:20,069 WARNING package apache2-data upgradable but fails to be marked for upgrade (E:Error, pkgProblemResolver:
:Resolve generated breaks, this may be caused by held packages.)
2021-08-15 06:20:27,730 WARNING package apt upgradable but fails to be marked for upgrade ()

I am skipping the rest, the list is long.

Then:

2021-08-15 09:26:42,522 ERROR failed to read deb file media-types (E:Could not open file media-types - open (2: No such file or 
directory))
2021-08-15 09:26:51,706 WARNING Package firewalld has conffile prompt and needs to be upgraded manually
2021-08-15 09:26:51,718 ERROR failed to read deb file firewalld (E:Could not open file firewalld - open (2: No such file or dire
ctory))
2021-08-15 09:28:59,915 INFO package firewalld not upgraded
2021-08-15 09:39:43,903 INFO package mime-support not upgraded
2021-08-15 09:54:09,093 INFO Packages that will be upgraded: apache2 apache2-bin apache2-data apache2-utils apparmor apt-transpo
rt-tor augeas-lenses augeas-tools avahi-daemon avahi-utils base-passwd bash batctl bind9 bind9-host bind9utils binutils binutils
-arm-linux-gnueabihf binutils-common bsdmainutils bsdutils btrfs-progs bzip2 ca-certificates certbot coreutils coturn cpio crack
lib-runtime crda cron curl dash dbus dbus-user-session dconf-gsettings-backend dconf-service debconf debconf-i18n debian-archive
-keyring debianutils debsecan diffutils dirmngr distro-info-data dkms dmidecode dmsetup dns-root-data dnsmasq-base dnsutils dosf
stools dpkg dpkg-dev e2fsprogs easy-rsa eject exfat-fuse exfat-utils ez-ipupdate fail2ban fakeroot fdisk file findutils firmware
-ath9k-htc firmware-linux-free flash-kernel fontconfig-config fonts-lato freedombox-doc-en freedombox-doc-es fuse gdbm-l10n gdeb
i-core geoip-database gettext gettext-base gir1.2-udisks-2.0 glib-networking-common gnupg gnupg-l10n gnupg-utils gpg gpg-agent g
pg-wks-client gpg-wks-server gpgconf gpgsm gpgv grep gsettings-desktop-schemas gzip hostname ieee-data ifupdown init init-system
-helpers initramfs-tools initramfs-tools-core ipset iputils-ping isc-dhcp-client isc-dhcp-common iso-codes iw javascript-common 
klibc-utils kmod krb5-locales ldapscripts less libacl1 libalgorithm-diff-perl libapparmor1 libapr1 libaprutil1 libaprutil1-dbd-s
qlite3 libaprutil1-ldap libasan5 libassuan0 libatomic1 libattr1 libaudit-common libaudit1 libaugeas0 libavahi-client3 libavahi-c
ommon-data libavahi-common3 libavahi-compat-libdnssd1 libavahi-core7 libb2-1 libbind9-161 libbinutils libblkid1 libblockdev-cryp
to2 libblockdev-fs2 libblockdev-loop2 libblockdev-mdraid2 libblockdev-part-err2 libblockdev-swap2 libblockdev-utils2 libblockdev
2 libbluetooth3 libbsd0 libbtrfs0 libbytesize1 libbz2-1.0 libc-ares2 libcap-ng0 libcap2 libcap2-bin libcc1-0 libccid libcom-err2
 libcrack2 libcryptsetup12 libcups2 libcurl3-gnutls libcurl4 libdaemon0 libdb5.3 libdbus-1-3 libdconf1 libdebconfclient0 libdevm
apper1.02.1 libdpkg-perl libedit2 libelf1 libestr0 libexpat1 libext2fs2 libfakeroot libfastjson4 libfdisk1 libfontconfig1 libfre
etype6 libfribidi0 libfstrm0 libfuse2 libgcrypt20 libgdbm-compat4 libgdbm6 libgeoip1 libglib2.0-data libgmp10 libgnutls-dane0 li
bgnutls30 libgomp1 libgpg-error0 libgpgme11 libgsasl7 libgssapi-krb5-2 libgudev-1.0-0 libhiredis0.14 libidn11 libidn2-0 libirs16
1 libisccc161 libisccfg163 libjansson4 libjpeg62-turbo libjs-bootstrap4 libjs-jquery libjs-modernizr libjs-popper.js libjson-gli
b-1.0-0 libjson-glib-1.0-common libk5crypto3 libkeyutils1 libklibc libkmod2 libkrb5-3 libkrb5support0 libksba8 libldap-common li
blmdb0 liblognorm5 libltdl7 liblua5.2-0 liblwres161 liblz4-1 liblzma5 liblzo2-2 libmagic-mgc libmagic1 libmariadb3 libmbim-glib4
 libmbim-proxy libmm-glib0 libmnl0 libmodule-find-perl libmodule-scandeps-perl libmount1 libmpc3 libmpfr6 libncurses6 libncurses
w6 libnetfilter-conntrack3 libnewt0.52 libnftnl11 libnghttp2-14 libnl-3-200 libnl-genl-3-200 libnl-route-3-200 libnpth0 libnss-l
dapd libnss-mdns libnss3 libntfs-3g883 libntlm0 libodbc1 libp11-kit0 libpam-ldapd libpam-modules libpam-modules-bin libpam-runti
me libpam0g libparted-fs-resize0 libparted2 libpcap0.8 libpci3 libpcre2-16-0 libpcre2-8-0 libpcre3 libpcsclite1 libpkcs11-helper
1 libpopt0 libpq5 libprotobuf-c1 libproxy1v5 libpsl5 libpwquality-common libpwquality-tools libpwquality1 libqmi-glib5 libqmi-pr
oxy librtmp1 libsasl2-2 libsasl2-modules libsasl2-modules-db libseccomp2 libselinux1 libsemanage-common libsemanage1 libsepol1 l
ibsmartcols1 libsodium23 libss2 libssh-4 libssh2-1 libssl1.1 libstemmer0d libtalloc2 libtasn1-6 libteamdctl0 libtevent0 libtext-
wrapi18n-perl libtinfo6 libubsan1 libuchardet0 libudisks2-0 libunbound8 libunistring2 libusb-1.0-0 libuuid1 libuv1 libvolume-key
1 libwebpdemux2 libwrap0 libx11-6 libx11-data libxau6 libxcb1 libxext6 libyaml-0-2 libzstd1 linux-image-armmp-lpae linux-libc-de
v login logrotate lsb-base lsb-release lshw lsof make manpages manpages-dev mariadb-common matrix-synapse-ldap3 mdadm modemmanag
er mount mtd-utils mysql-common nano ncurses-base ncurses-bin ncurses-term needrestart net-tools netbase netcat-openbsd nftables
 node-jquery nodejs-doc nslcd nslcd-utils ntfs-3g obfs4proxy opensc opensc-pkcs11 openssh-client openssh-server openssh-sftp-ser
ver openssl openvpn parted passwd patch pciutils pcscd pinentry-curses powermgmt-base procps psmisc publicsuffix pwgen python-ap
t-common python3-acme python3-argon2 python3-asn1crypto python3-atomicwrites python3-attr python3-augeas python3-automat python3
-bcrypt python3-bleach python3-bootstrapform python3-bs4 python3-canonicaljson python3-certbot python3-certifi python3-chardet p
ython3-cherrypy3 python3-click python3-colorama python3-configargparse python3-configobj python3-constantly python3-cryptography
 python3-dateutil python3-debian python3-decorator python3-distro-info python3-django-appconf python3-django-axes python3-django
-captcha python3-django-ipware python3-django-ranged-response python3-django-stronghold python3-frozendict python3-future python
3-hamcrest python3-html5lib python3-hyperlink python3-idna python3-incremental python3-jinja2 python3-josepy python3-ldap3 pytho
n3-mock python3-nacl python3-netaddr python3-olefile python3-openssl python3-pampy python3-paramiko python3-pbr python3-phonenum
bers python3-pkg-resources python3-ply python3-prometheus-client python3-pyasn1 python3-pyasn1-modules python3-pyinotify python3
-pymacaroons python3-radicale python3-repoze.lru python3-requests python3-requests-toolbelt python3-rfc3339 python3-routes pytho
n3-service-identity python3-setuptools python3-signedjson python3-sortedcontainers python3-soupsieve python3-sqlparse python3-tr
eq python3-typing-extensions python3-tz python3-unpaddedbase64 python3-urllib3 python3-vobject python3-webencodings python3-webo
b python3-zope.component python3-zope.event qttranslations5-l10n radicale readline-common sensible-utils shared-mime-info sharut
ils ssl-cert sudo systemd-sysv sysvinit-utils tar tasksel tasksel-data tdb-tools telnet torsocks ttf-bitstream-vera tzdata u-boo
t u-boot-exynos u-boot-imx u-boot-omap u-boot-sunxi u-boot-tools ucf udisks2 usb-modeswitch usb-modeswitch-data usb.ids usbutils
 util-linux vim-common vim-tiny wamerican wget whiptail whois wireguard wireguard-dkms wireguard-tools wireless-regdb xauth xxd 
xz-utils zlib1g
2021-08-15 09:54:09,099 INFO Writing dpkg log to /var/log/unattended-upgrades/unattended-upgrades-dpkg.log
2021-08-15 13:32:16,962 ERROR Exception happened during upgrade.
Traceback (most recent call last):
  File "/usr/bin/unattended-upgrade", line 610, in cache_commit
    res = cache.commit(install_progress=iprogress)
  File "/usr/lib/python3/dist-packages/apt/cache.py", line 684, in commit
    raise SystemError("installArchives() failed")
SystemError: installArchives() failed
2021-08-15 13:32:18,689 ERROR Exception happened during upgrade.
NoneType: None
2021-08-15 13:32:18,706 ERROR Installing the upgrades failed!
2021-08-15 13:32:18,709 ERROR error message: installArchives() failed
2021-08-15 13:32:18,724 ERROR dpkg returned a error! See /var/log/unattended-upgrades/unattended-upgrades-dpkg.log for details
2021-08-15 13:34:02,014 ERROR Exception happened during upgrade.
Traceback (most recent call last):
  File "/usr/bin/unattended-upgrade", line 610, in cache_commit
    res = cache.commit(install_progress=iprogress)
  File "/usr/lib/python3/dist-packages/apt/cache.py", line 684, in commit
    raise SystemError("installArchives() failed")
SystemError: installArchives() failed
2021-08-15 13:34:05,344 ERROR Auto-removing the packages failed!
2021-08-15 13:34:05,349 ERROR Error message: installArchives() failed
2021-08-15 13:34:05,352 ERROR dpkg returned an error! See /var/log/unattended-upgrades/unattended-upgrades-dpkg.log for details
2021-08-15 13:34:05,646 WARNING Found /var/run/reboot-required, rebooting
2021-08-15 13:34:05,764 WARNING Shutdown msg: b"Shutdown scheduled for Mon 2021-08-16 02:00:00 UTC, use 'shutdown -c' to cancel.

Is a manual upgrade needed? How?

Besides, my contact server with radicale seems broken.

EDIT: Is it a good idea to do an unattended upgrade to switch to Debian 11.0 exactly when it is released? Is Debian 11.0 compatible with all the freedombox packages?

my ejabberd attachments are not working

message on client states failed to connect to port 5443

any thoughts?

Did you have the unattended upgrade to Bullseye too?

@Avron:
My radicale also has hick-ups, had to create 2 new calendars, error 500. That is surely a different topic. (This happend prior to the upgrade, about 2-3 weeks ago).
And also Syncthing is not running, since 4-6 weeks, I guess. Hope this resolves with the upgrade.

PS: see my EDIT2 in the first post with the broken file. That might be the cause of the failing upgrade.

In Bullseye, python-django-common is now a virtual package provided by python3-django.

On my box (already upgraded to Bullseye), the file /var/lib/dpkg/info/python-django-common.list is empty.

# ls -al /var/lib/dpkg/info/python-django-common*
-rw-r--r-- 1 root root   0 Aug 15 12:52 /var/lib/dpkg/info/python-django-common.list
-rwxr-xr-x 1 root root 195 Jun 14  2020 /var/lib/dpkg/info/python-django-common.postrm

And this package is not installed:

# apt policy python-django-common
python-django-common:
  Installed: (none)
  Candidate: (none)
  Version table:
     1:1.11.29-1~deb10u1 -1
        100 /var/lib/dpkg/status

So the best way is to do a re-install with Bullseye?

I think this problem is related to this comment

When can we expect new images to download for Bullseye? I am running on LIME(1).

Joseph is working updating the build infrastructure to create new stable images. Images should be available in a few days.

Great, I will run a new new install with Bullseye then. It was easy the last time I did.
We have to improve reliability of the FreedomBox in order to make it “mainstream” feasible. What could be the cause of the failure of the upgrade? Did it work for anyone flawlessly? It might be a faulty µSD card on my side which crashed the python-django-common.list file. Therefore, I would like to understand if more users had issues or not with the upgrade.

I did have issues, but not sure if it was the upgrade or maintenance work from my cable provider, which happened around the same time. I was locked out on my box via domain name. TOR and IP still worked, but http only. I went to the GnuDIP page and updated my settings, which did the job. Miraculously my ejabberd config was somehow cured after the update as well.

My pioneer box seems fully functional after upgrade to Bullseye but:

  • cockpit reports that calible content server failed to start (I have not clue what this is)
  • the sources seem to refer to bullseye and some packages are indicated as upgradable:
root@fbox:/etc/apt# cat sources.list

deb tor+http://deb.debian.org/debian stable main
deb-src tor+http://deb.debian.org/debian stable main

deb tor+http://deb.debian.org/debian stable-updates main
deb-src tor+http://deb.debian.org/debian stable-updates main

deb tor+http://security.debian.org/debian-security/ stable-security main
deb-src tor+http://security.debian.org/debian-security/ stable-security main

root@fbox:/etc/apt# cat sources.list.d/*                
# This file is managed by FreedomBox, do not edit.
# Allow carefully selected updates to 'freedombox' from backports.

deb tor+http://deb.debian.org/debian bullseye-backports main
deb-src tor+http://deb.debian.org/debian bullseye-backports main

root@fbox:/etc/apt# apt list --upgradable
Listing... Done
freedombox/stable 21.4.4 all [upgradable from: 21.4.4~bpo10+1]
guile-2.2-libs/stable 2.2.7+1-6 armhf [upgradable from: 2.2.4+1-2+deb10u1]
sshfs/stable 3.7.1+repack-2 armhf [upgradable from: 2.10+repack-2]
tor-geoipdb/stable-security 0.4.5.10-1~deb11u1 all [upgradable from: 0.4.5.9-1]
tor/stable-security 0.4.5.10-1~deb11u1 armhf [upgradable from: 0.4.5.9-1]
root@fbox:/etc/apt# 

Should I try “apt upgrade” in command line?
What is version 21.4.4~bpo10+1 of the freedombox package as compared to 21.4.4?

About reinstall everything from a bullseye image: I don’t know how to restore all the accounts and data from my backups on a fresh image, and whether I should use a backup from before the upgrade to Bulleye or just from now.

It is this issue: calibre: Service tries to start before app is installed (#1982) · Issues · FreedomBox / FreedomBox · GitLab
If you don’t use Calibre, then you can just ignore it.

21.4.4~bpo10+1 is nearly identical to 21.4.4, but 21.4.4 will try to replace fuse with fuse3. (freedombox and sshfs being upgraded at the same time should cause this replacement.)

Before using the command line, have you tried the “Manual Update” feature on the System → Update page of FreedomBox interface?

The following happened in the early morning today (before I tried manual upgrade):
This is from /var/log/unattended-upgrades/unattended-upgrades.log

2021-08-24 06:04:40,653 INFO Starting unattended upgrades script
2021-08-24 06:04:40,669 INFO Allowed origins are: origin=Debian,codename=bullseye,label=Debian, origin=Debian,
codename=bullseye,label=Debian-Security, origin=Debian,codename=bullseye-security,label=Debian-Security, o=Deb
ian Backports,a=bullseye-backports,l=Debian Backports
2021-08-24 06:04:40,673 INFO Initial blacklist: 
2021-08-24 06:04:40,676 INFO Initial whitelist (not strict): 
2021-08-24 06:05:28,615 INFO Packages that will be upgraded: tor tor-geoipdb
2021-08-24 06:05:28,618 INFO Writing dpkg log to /var/log/unattended-upgrades/unattended-upgrades-dpkg.log
2021-08-24 06:08:25,916 ERROR Lock file is already taken, exiting
2021-08-24 06:15:32,505 INFO All upgrades installed
2021-08-24 06:15:36,646 INFO Package freedombox is kept back because a related package is kept back or due to 
local apt_preferences(5).
2021-08-24 06:15:36,820 INFO Package guile-2.2-libs is kept back because a related package is kept back or due
 to local apt_preferences(5).
2021-08-24 06:15:38,645 INFO Package sshfs is kept back because a related package is kept back or due to local
 apt_preferences(5).

The “ERROR Lock file is already taken” appears only once in the log file, so this is new. I did not try anything new yesterday (besides looking into cockpit). Apparently, the tor package was upgraded.

I just tried the manual update in the web interface, the same packages are still upgradable, cockpit now says that freedombox-manual-upgrade.service failed to start.

I could try the command line update but I am a bit worried by the “Lock file is already taken”.

This typically means that another update process is running.

I think you can try the command line update. If the lock file is still taken, it will not do anything, but will let you know about this.

“apt -s upgrade” says it will not upgrade 3 packages.

I tried “apt -s install packageX” for each upgradable package

  • freedombox: will remove fuse
  • sshfs: will remove fuse
  • guile-2.2-libs: will remove libgc1c2

I understand from your previous answer that removal of fuse is ok.
Is the removal of liggc1c2 ok?

Should I do “apt upgrade --with-new-pkgs” to avoid marking them as manually installed if I ask to install them? (what I think I understood from searching for such kind of situation)

The problem is that this only installs one package at a time.

The way the fuse → fuse3 transition was handled, requires freedombox and sshfs to both be upgraded at the same time.

It’s ok to remove fuse, as long as fuse3 is getting installed in its place.

I’m not as familiar with libgc1c2, but I think it’s ok to remove, as long as libgc1 is getting installed in its place.

I successfully did the upgrade of the 3 packages with a single “apt install” command.
I now have v21.7 of freedombox.

Thanks !

During the upgrade, apt complained several times about locales, with messages such as:

Failed to set locale. Fix your system.
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
	LANGUAGE = (unset),
	LC_ALL = (unset),
	LC_TIME = "fr_FR.UTF-8",
	LC_MONETARY = "fr_FR.UTF-8",
	LC_ADDRESS = "fr_FR.UTF-8",
	LC_TELEPHONE = "fr_FR.UTF-8",
	LC_NAME = "fr_FR.UTF-8",
	LC_MEASUREMENT = "fr_FR.UTF-8",
	LC_IDENTIFICATION = "fr_FR.UTF-8",
	LC_NUMERIC = "fr_FR.UTF-8",
	LC_PAPER = "fr_FR.UTF-8",
	LANG = "fr_FR.UTF-8"
    are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").
locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Cannot set LC_MESSAGES to default locale: No such file or directory
locale: Cannot set LC_ALL to default locale: No such file or directory

I have the web interface in French, formatting according to conventions in France and the logs/system messages in English, and these are exactly my preferences.

Should I do something to avoid the “no such file or directory” that sounds a little worrying?