Lost all access to FreedomBox

Problem Description
I cannot access my FB anymore. Not even from SSH (router does not see it on the LAN).

Steps to Reproduce

  1. Try to access any service provided by FB or to connect via SSH.

Actual results
No response, host is offline.


  • FreedomBox version: unknown, since it was supposed to upgrade during the night.
  • Hardware: OLinuxino-Lime2
  • How did you install FreedomBox?: from downloaded image, burnt on SD card with etcher.

The router show the last connection being during the night, at about the time the FB should have been upgrading.
I have seen this post [SOLVED] Random errors, no SSH connection - #2 by jvalleroy, but in my case, the SD card still has a lot of free space.
I have also check this post : Upgrade to Bullseye - #6 by Dietmar, but it seems in this case, the connection to the FB still works.
I have also tried rebooting the FB (with the Lime2 hardware buttons), but it is still unreachable.
What should I do ? Is there a way to access the logs directly on the SD card ? If so, what should I provide to further investigate ?

Thanks for your time. :slight_smile:

EDIT: another “hint” : I do not know if it is related, but the day before, while the FB was still accessible, the mediawiki instance was showing an error. I think it was a “database error”, but I did not have time to check it then.

Hi Altadil,

sorry to hear that you are facing issues accessing your FB. As for accessing logs directly from the SD card, yes this is possible. I found out about missing hard disk space in the thread[0] you are mentioning this way.

I simply powered down the FB, removed the SD and plugged it into a card reader on my desktop. From there, I could simply mount the partitions (presumably the largest will be the ‘/’ mount point on the FB) and navigate to /var/log on it to check the various log files. (NB: I am running Debian stable on my desktop which has support for btrfs, so this may not be possible if you’re using a Windows or Mac. You may be able to use a live medium in that case.)

I hope you can pinpoint the root cause of your issues this way.


[0] [SOLVED] Random errors, no SSH connection - #2 by jvalleroy



thank you for your help.
I have been able to access the logs and see diverse errors such as held packages, for instance. Unfortunately, I can’t make anything out of it ; I’m afraid this is out of my skill level. :confused:

I guess I will have to re-install. I do have a back-up, but I am trying to get the most recent data from the FB. The way I do it is by copying the same directories I see in my normal FB backup (done with the FB backup app). Am I correct in assuming this will work when I use the import function in the new FB ?


I have the same problem, as you @Altadil.
Ethernet is recognized and activated by bullseye-kernel, but link does not receive an IP via DHCP.
Using static IP also does not work.

I think in my case it is a known problem: Olimex A20-OLinuXino-LIME2 rev. F and newer and bullseye kernel
My Board is an Olimex A20-OLinuXino-LIME2 rev. G
On above wikipage there is an explanation, how to build an boot loader image with changed configuration.
But I dont understand completely how to do this. I dont have a debian installation at hand and my knowledge of U-Boot and Kernel-configuration is very limited.
Maybe someone in this forum can help?
Is it possible to provide an complete build of bootloader as img-file, which we could just dd on our sd-card?

1 Like

Hi andih,

thanks a lot for your help. I have been able to connect to my new FB install (unfortunately, I had already wiped the old one before seeing your reply :crying_cat_face:).
I installed Debian in a VM and “blindly” followed the instruction from the Debian wiki page you linked and it worked. I don’t know your general skill level, but if you want, I can try to write down the detailed steps I did ?
EDIT: I can also attach the file, but I have no idea whether that will work. :confused:

Hi Altadil,

Nice to hear thet it wored for you.
Meanwhile I also did a reinstall, but used the image of the Pioneer Edition which also is an Olimex A20-OLinuXino-LIME2
It already has the correct bootloader or configuration in the base image.
None the less it took me a lot of work to reinstall all the software and get it running.