Update not working

New Freedombox

Got an error when trying to install ejabbered (see previous post)

Went to get the screenshot of the about box as requested and I noticed it said my FreedomBox needed an update. I tried the autoupdate and nothing happened. So I tried the manual update and it churned away for a while, but in the end came back with the same screen saying my FreedomBox was not up to date

Hi Phil, it looks like your box is still on Debian Buster and you can take the upgrade to Bullseye. I’m not sure if there is a way to do it besides in the terminal, but it’s fairly straightforward:

sudo apt update && sudo apt upgrade - y

After that finishes:

sudo apt full-upgrade

To remove any packages no longer needed after the upgrade:

sudo apt autoremove --purge

From there I would reboot and try again with the stuff you were trying to set up.


Hello @Phil

It would be best to let Freedombox to do the upgrade.
Go to the ‘System’ tab in your Freedombox, and open the ‘Update’ tab and ‘Enable auto-update’ and ‘Enable auto-update to next stable release’, then ‘Update setup’.

Or: https://freedombox.local/plinth/sys/upgrades/

It may take a day or two, too upgrade your Freedombox.

Regards: peter


Ok I have FreedomBox up to the current release I believe running on Debian Bullseye

But when I try and install ejabberd I still get the following error - same as before:

Thanks in advance for your help

Here is a screen grab showing the version I am running

I get the same error if I try and install Coturn

These are the only 2 apps I have tried to install - so assume it is the same for the rest of the apps as well.


Auto update is enabled

Take a look at this post to see if it applies. It mentions the same message following upgrade from buster. The key point is:

Upon closer look, it seems that the content of /etc/apt/sources.list is no longer valid. stable/updates should read stable-security. So, where it reads:

deb http://security.debian.org/debian-security/ stable/updates main
deb-src http://security.debian.org/debian-security/ stable/updates main

it needs to be changed to:

deb http://security.debian.org/debian-security/ stable-security main
deb-src http://security.debian.org/debian-security/ stable-security main

1 Like

Progress. For any other non-techies following a long, I found this article helpful in working out how to edit the file https://www.howtogeek.com/102468/a-beginners-guide-to-editing-text-files-with-vi/

So I can now install ejabberd and coturn.

But I still get these messages in the software update part of cockpit:

and when I click the install all button I get:


What should I do?

Also Cockpit says Automatic Updates are not turned on


Should they be (they show as turned on in the FreedomBox interface) and if so how do I turn them on?

Regarding packages held back during upgrade to bullseye, see this thread and Issue 2103. You generally don’t need Cockpit to manage updates. The Cockpit message is a red herring. I had several packages held back, but after a couple of days of automatic updates, I was left with just one package that I ultimately had to handle manually. As mentioned in the thread, you can use “apt -s install packageX” to see what will happen if you manually update a package. I looked at the package dependencies and found that I had to remove libgc1c2 to get libgc1 installed:

god@freedombox:~$ sudo apt-get remove libgc1c2
[sudo] password for god:
Reading package lists… Done
Building dependency tree… Done
Reading state information… Done
The following package was automatically installed and is no longer required:
Use ‘sudo apt autoremove’ to remove it.
The following additional packages will be installed:
guile-2.2-libs libgc1
The following packages will be REMOVED:
The following NEW packages will be installed:
The following packages will be upgraded:
1 upgraded, 1 newly installed, 1 to remove and 0 not upgraded.
Need to get 5160 kB of archives.
After this operation, 39.9 kB of additional disk space will be used.

1 Like

You are a champion. That fixed it.

Thanks very much.

Do you know when they are going to update the image that they ship with the Pioneer so new users will not have these problems?