[SOLVED] Trouble registering on gnudip.datasystems24.net

I tried self-registering at https://gnudip.datasystems24.net a few hours ago, and while the registration page didn’t give me an error, I was never able to log in (the login page said I wasn’t a user, or something to that effect).

To be clear, I mean that I think new registration is broken at https://gnudip.datasystems24.net

@Dr_Scribble Just checked self-registration. Works fine.

Did you selected correct domain on login form?

1 Like

Yes I did. And I just tried registering again with two browsers (Firefox and Safari) and got the same result: registration said it went fine, but it clearly didn’t, because I got:

"Error: Unknown User

"You entered a username/domain combination which was unknown.

“Please go back and check for typos.”

My Firefox has a weird setup but not my Safari, so I don’t think it has anything to do with browser settings. I also tried using a different password, with only alphanumeric characters. The domain name doesn’t have any weird characters in it (just alphabet and underscores). The length of the domain name (NOT including the “.freedombox.rocks”) is less than 30 characters. My email address doesn’t have any special characters in it. I’m selecting the right domain in the drop-down menu both for registration and trying log in afterwards. I’m not connecting from any weird network.

I just realized that underscores are by convention (at least) not part of hostnames, so I tried self-registering one without, but had the same outcome.

Someone else recently had trouble using capital letters. Are you using all lower-cased letters?

Yes, all lowercase for the hostname (and when setting it I did not include the “.freedombox.rocks” part but selected it in the drop-down menu).

I haven’t, but that wouldn’t make sense. I’m talking about trying to “self-register” a hostname at https://gnudip.datasystems24.net, not configuration in Plinth.

I went through the registration to see if I would get stuck too, but it seems like it is working.

Did you get to this screen where you clarify your IP address? Then there is a button to go into the settings.

In the settings is the consent to transfer the data over.

Or are you getting stuck before you get into that part?

1 Like

I’m getting stuck before that:

  1. I go to https://gnudip.datasystems24.net and press the “Self Register” button.

  2. I enter this information into the web form:
    Domain (this is the pull down menu and I select “freedombox.rocks”
    E-Mail Address
    Password Again

  3. I press the “Register” button and it indicates everything went fine.

  4. I go back to the login page (in #1) and try to log in, and that fails with the message I included up above in this thread somewhere.

Have you tried using the forgotten password tool? It might help indicate whether an account was successfully created or not.

There’s no forgotten password. I’ve tried starting from scratch.

It seems likely that self-registration is broken, and whatever the reason is, it didn’t affect the owner of the system when he tried it out (somewhere up above). That’s why I tried to think of factors that might give a different result than he had with his test case.

Try setting a simpler password (along with the simpler domain/user name). Perhaps there is a bug in type/length of password stored.

@Dr_Scribble honestly, that’s what I was starting to think too–that it was broken and you would probably have to wait until next week and try again once they get the new server set up.

I decided to try to go through the registration myself to test it out (my screenshots above are from that effort). I hadn’t previously used this service (I have a duckdns.org account set up that works fine for my DDNS stuff), and I’m not a developer or advanced user.

The registration and subsequent login were both straightforward and simple in my case, which makes me think maybe it is just a buggy configuration like Sunil mentioned. The domain name I used was all one word (no dots or dashes), I have no idea if that would make a difference but maybe it’s worth a shot.

1 Like

Your success inspired me to try again, thanks.

So it was something about the hostname that caused self-registration to silently fail. The hostname I was trying to get working had 22 characters and two dashes (should have been fine). I just tried one with 10 characters, alphabetical and digits, and that worked.


Thanks folks, looks like this is a bug in the GnuDIP server software we use for DDNS functionality. I have also split this conversation into a separate thread so others can find it easily.