Setup - Error 500

Hi Support,

I have done the following as instructed in the Manual:

  • Plugin the battery
  • Plugin the cable and power
  • Plugin the SD-card
  • Check my router IP -

Month and year you bought your kit: October 2021
PN: 0000099697

After I entered, the Install-01
appeared (see image).
I clicked “Start Setup”, and it came out this error 500 page

URL shows the following:

Please advise on how to trouble-shoot this installation process. Thanks!

@sgventureslab you mentioned your router’s IP address is but it looks like that is also the IP address for the box, is that right?

It seems odd to me that your router and Freedombox would share the same IP address. Did you set it up that way intentionally? I’m not very experienced with networking or anything, but I guess what I would expect is your router to assign an IP address to the box with DHCP.

Does your router have a web interface? That broken web page you are getting reminds me of an issue I had after I set up Pihole on the box, and Pihole and Freedombox were both trying to broadcast to port 80 on the same IP address.

1 Like

I did enter into my router admin, and noticed that was assigned to Freedombox…the router IP is…FreedomBox-IP

Oh gotcha! I misinterpreted what you had written there, sorry about that. I thought maybe there was a mixup with the IP assignments on your network.

Since you obviously haven’t changed anything yet (since the installer didn’t even run) I’m kind of at a loss where to begin.

What browser are you using?

Does it make a difference if you navigate to (omitting the “s” in https)?

1 Like

I have tried using Firefox and Chrome…and both gave the same outcome…

The “s” will automatically appears …https

Yes, both of those browsers will automatically add the “s” if they can. You have to load the page, then click into the address bar and delete it.

I only mention it because occasionally I will get a different page to load if I omit the “s”.

Does your router have a firewall configuration page? If so, what does it say?

1 Like

It would also help to look at the Network tab in the Developer Console of Firefox and see why the images, scripts and CSS files are not showing up.

BTW, does the page load very slowly?

@sgventureslab , you can also download and write the FreedomBox image for Pioneer Edition onto the SD card (perhaps a different SD card). This would completely reset any issues with the software on the SD card and any SD card disk errors.

Ok…I’ll try this …and see how it goes. thanks

My Firefox still rejecting the Certificate when I tried to get the browser to accept it…

I clicked on Accept the Risk and Continue…and it is still not showing the right page…

It looks like you got past that error 500 screen, so that’s good!

This warning message is completely normal behavior for your browser. It’s a security feature. Probably all of us here had to accept that warning the first time we set up the box.

If you were browsing the internet and got that message you should be suspicious, but in this case it is literally your own computer that you set up yourself on your own network. Just accept the “risk” and allow Firefox to add the site as an exception to its certificate policy.

Once you get into the web interface you can get an actual certificate going if you want to through System–>Let’s Encrypt. In fact, after I set up my dynamic DNS client with a duckdns domain, my FreedomBox automatically set up a valid certificate for me–I didn’t even have to do anything!

I tried many times to Accept the Risk, but I the box to Permanently store the exception does not show up for me to click…so i could not confirm Security Exception…

I thought it might be the SD-card corrupted, so got another SD-card, downloaded the image and Etcher to burn the image into the SD-card, but it still cannot get setup…

It shows this…

then when I clicked Start Setup,
it shows the following URL:
with a blank page…

Looks like it cannot load the images, etc…

That’s odd. Are you able to accept the temporary exception that it offers?

I opened Firefox on my computer (not my normal browser) to see if I could recreate what you have, but my Firefox lets me through with no resistance, and automatically adds the exception for the site.

Is your browser up to date? It looks a bit different than mine, I guess that could be different OS though.

Are you getting two different results from the two SD cards?

Did you download the freedombox-stable-free_pioneer_a20-olinuxino-lime2-armhf.img.xz from /pub/freedombox/pioneer (modified 7/19/2019), or from /pub/freedombox/pioneer/weekly (modified 11/12/2021)?

I am using Windows 10 and it is up-to-date.
I have also checked the Firefox browser and it is also up-to-date…

I tried both the SD-cards; one that came with the Pioneer box, and the one I burned using Etcher and the new image…both gave the same result…

Seems like it does not load the Setup…

Can you post a screenshot of your firewall configuration on your router web UI? How about your Windows Defender Firewall config?

I am using Linksys Router…

I have tried disabling my Avast Internet Security application to check whether it might be the application that block the installation, but it still shows me the same result…

Do you have any extensions / add-ons in the browser that might be blocking it?

I just turned off all the extensions and it still shows the same result…tried with other browsers too…so might be something else causing this…