[SOLVED] Web URL connects to Apache2 Debian default page with Pihole installed

Hello, I am somewhat new to Linux and networking, learning quickly but in just a day of tinkering with my new box I am afraid I somehow messed up the web URL. Instead of taking me to the FreedomBox page it takes me to the Apache2 Debian default page.

Steps to Reproduce
Enter FreedomBox IP address, or freedombox.local at URL bar.

Expected Results
FreedomBox UI

Actual results
Apache2 Debian default page

This is the pre-installed hardware version of Freedombox. When I first set it up, the web page loaded up just fine.

So far the only thing I have done with the box is SSH into it and install Pi-hole (which required apt upgrade first), so I have to guess something about how I did that caused this issue.

I do see files that appear to be related to the FreedomBox site in /usr/share/freedombox/manual/en, but the IP address pulls from /var/www/html/index.html.

I did look through the /etc/apache2/apache2.conf file, but I am afraid it may as well be in Greek, I’m just in way over my head.

I apologize for this question not being more informative, please let me know what additional clarifying information I can pass along.

Hello @BluishHumility

This url will take you to the ’ Configure ’ page for your Freedombox: https://freedombox.local/plinth/sys/config/

On the ’ Configure ’ page you will see ’ Webserver Home Page ’ section. From the drop down menu, pick ’ Freedombox Service (Plinth) '. Then at the bottom of that page click ’ Update setup '. This will set Plinth as your landing page for your Freedombox.

Regards: peter

Hi Peter, thanks for getting back to me.

Unfortunately I am getting a “this site can’t be reached/freedombox.local refused to connect” message when I try to connect to the URL you posted above.

If I remove the “s” from the https in the URL you sent me I get this weird broken page. It seems to have text related to both FreedomBox and Pihole.

The box is connected and running. I can interact with it through SSH without a problem.

I apologize for my lack of experience here, but it just occurred to me that the Pihole software I installed on the box also has a local IP address web interface–I am wondering if that is creating a problem?

The Pihole web interface is working normally, (192.168.0.9/admin/index.php).

192.168.0.9 or freedombox.local opens the Apache2 Debian default page.

https://freedombox.local/plinth/sys/config/ is the broken link.

I’m feeling a bit sheepish here for messing this up in only a day…any possibility I can salvage the web interface?

Peter,

I just wanted to pass along a quick update. I did a little reading and learned that the Pihole and FreedomBox web servers were competing for port 80 and that is why I wasn’t able to get the site up.

I tried to change the port Pihole uses, but was unsuccessful because either bugginess in the configuration or I was doing it wrong.

After a bit of hacking around I was able to change the FreedomBox port number (there is a lot of documentation available for Apache2, thankfully), now the web interface is back up and it looks like both UIs will be able to coexist peacefully (knock on wood!).

Thanks again for your help!

1 Like