What do we do after another unsuccessful update?

After the failure and headaches after the update from buster to bullseye, I was dreading the day when the new one would start. My reluctance to let this moment come was totally justified: nothing worked after it. The only way I can connect to freedombox is with an HDMI cable. There is no other connection, no ssh, no localhost, nothing. So support team, what are we doing now?

1 Like

It is late for me now and I need to go to sleep, so I’ll be brief now.

I’d suggest checking the status of update (see if it completed), whether services are running and whether the firewall is dropping packets. I have somehow explained how I did that in my posts, if that is not understandable enough, I’ll try explaining more. At least, I can help solving the problems I had if you have the same.

Sorry, but I’m not very familiar with terminal commands. I can only transcribe such. I don’t know how to check if the firewall drops packets. I tried the commands you posted in another thread and it doesn’t work. Every time I try to update, upgrade or dist-upgrade I get multiple error lines: "Could not resolve ‘deb.debian.org’ ". As I already mentioned above, I have no other connection than a cable to a monitor and a keyboard connected directly to the server.

I tried, even after the first command I get multiple lines of errors. I can’t read because they change very quickly and I have no idea how to get the lines back to see them, but I think most of them are related to the one in the picture I’m attaching.

Address resolution fails.

I can think of the following way to check whether it is because of the firewall:

  • run “sudo su -”
  • run “nano /etc/firewalld/firewalld.conf”
  • there is a line “LogDenied=off”, change it to “LogDenied=all”, write (Ctrl+O) and exit (Ctrl+X)
  • run “systemctl restart firewalld.service”
  • run “journalctl --unit=firewalld.service -f &” (the command continues running even though you have a prompt)
  • run “ping deb.debian.org

If you see some lines with “kernel” and “REJECT”, this means the firewall is the problem. If you don’t see any, it isn’t the firewall. To interrupt the last command, do Ctrl+C. To go back to the journalctl command, enter “fg” (it means foreground), then Ctrl-C. Then re-edit /etc/firewalld/firewalld.conf" to set LogDenied to its original value (off). Then exit to exit the root shell.

If it is the firewall, I hope others can help because yesterday is the first time in my life that I tried looking at the firewall.

Thanks for the reply. I wrote all the commands. I upload a photo with the result. Again there is no connection with deb.debian.org

So the firewall is not the problem.

What does “ping” give? and “Ip a”?

“ping” gives “ping: connect: Network is unreachable”, and “Ip a” - bash Ip: command not found

Sorry, I mistyped, I meant “ip a” (not “lp”). Your network interface seems completely non-functional for some reason, “ip a” should say how it is configured.

Now after an attempt for restoring the system from a snapshot, already everything is non-functional. I will start from scratch again. Thank you for your time and effort to help me.

I hope your reinstallation goes well.

When the services on my Freedombox were not working after the upgrade, I was in big stress of not being able to receive and send emails and XMPP messages on the accounts hosted on my Freedombox.

When I found the solution of the firewall, I was about to attempt restoring from a snapshot and if that failed to reinstall. However, there can be circumstances in which I don’t have the time or physical possiblity to do that and this makes me think that it is a problem to rely on my Freedombox for somehow essential things.

It would be nice to be able to run a second Freedombox in order to maintain essential things available in case of failre but I need to think how to do. One issue I can think of is renewal of Let’s encrypt certificates, that would require to redirect HTTP traffic to the “backup box” before renewal and back to the “main box” after. Perhaps a new feature to suggest?


My FreedomBox is down at the moment and had the same idea come to me. If one could two working in tandem, one could still be up while the other is performing the upgrade process. I’m on my second day without my FreedomBox and I can feel its absence. I’m still hoping that it will complete the update on its own.

Hello, I am new in the forum, don’t speak very goog english. My problem is that the webaccout, the synchronisation with radicale and shaarli don’t work. I can access via SSH and I see that 12 updates could not be installed automatically. I can ping succsessfull my PC or my cellphone. What can I do to make work again all? Thank you for your help.

  • check whether /boot is full. If it is full, remove the oldest kernel package (lowest number)
  • run sudo apt update, sudo apt upgrade and, if some packgages are still not updated, sudo apt full-upgrade
  • check /etc/firewalld/firewalld.conf, if there is “DefaultZone=public”, change it to “DefaultZone=external”, save the file and run “sudo systemctl restart firewalld.service”
  • try again webaccess

thank you!

I waited five days for the Debian 12 upgrade to complete, the web interface didn’t come up on its own, it gave Bad Gateway error.

your solution worked!

"check /etc/firewalld/firewalld.conf, if there is “DefaultZone=public”, change it to “DefaultZone=external”, save the file and run “sudo systemctl restart firewalld.service”


this has worked for me many times when I have met “Could not resolve deb.debian.org

1 Like

Thank you! I tried it, but it didn’t work for me. I just made a fresh installation.

1 Like

Thank you! :grinning: :grinning: :grinning: :grinning: :grinning: :grinning: :grinning:

After doing what Avron suggested (a post before you), your advice made my freedombox finally reachable again. Thanks.