[SOLVED] SSH host public key could not be verified on create a Backup Location

(When looking for a solution to a problem you are facing, providing a structured, detailed description of the problem will help others provide a quick response)

Problem Description
(I am tried to enable public registrations in Matrix Synapse app and got an error.)
I am tried to create my first remote backup location. After I pu data of conecction, I recieved the error “SSH host public key could not be verified.”

Steps to Reproduce

  1. Login to FreedomBox.
  2. Go to Backups
  3. Click on Add remote backup location
  4. Inset data for conection,
  5. choose none crypt
  6. wat the error message

Expected Results
I expected to see a message confirming my new remote backup location

Actual results
I get an error with the following message: SSH host public key could not be verified.



  • FreedomBox version: You are running Debian GNU/Linux 11 (bullseye) and FreedomBox version 22.8. FreedomBox is up to date.
  • Hardware: Rpi 3B+
  • How did you install FreedomBox?: Downloaded image for Rpi extract file, and use DD to transfer to microsd.

Is the device something you connected to FBX with an SSH session previously (for something else)?

If so, a key already exists. You will have to either connect using that key, or delete the existing key from the ~/.ssh directory.

1 Like

I cleanned the file and now it work’s.
echo "" > /var/lib/plinth/.ssh/known_hosts

1 Like