[SOLVED] Plinth login for admin account not possible anymore

Problem Description

I cannot log into plinth with my admin account anymore.

  • 2 plinth accounts: 1x ‘admin’ account , 1x non-privileged ‘user’
  • tried accessing the FBX both from local network (192.168…) and external hostname (box.example.org)
  • login as ‘admin’ user shows the default error message: “Please enter a correct username and password. Note that both fields may be case-sensitive.”
  • password and username are correct and have not changed recently
  • login as regular ‘user’ is still possible
  • login via SSH with the ‘admin’ user is also possible (I enabled this after a recent update that changed the defaults to prevent sudo-users from logging in)

Logs

The logs (as per journalctl -u plinth) show my failing admin login with a successful (regular user) login afterwards:

May 18 16:08:02 fbox /usr/bin/plinth[570355]: AXES: User login failed, running database handler for failure.
May 18 16:08:02 fbox /usr/bin/plinth[570355]: AXES: New login failure by {ip_address: "192.168.178.31", path_info: "/accounts/login/"}. Created new record in the database.
May 18 16:08:15 fbox /usr/bin/plinth[570355]: AXES: Successful login by {ip_address: "192.168.178.31", path_info: "/accounts/login/"}.
May 18 16:08:15 fbox /usr/bin/plinth[570355]: AXES: Reset 2 access attempts from database.
May 18 16:08:15 fbox /usr/bin/plinth[570355]: AXES: Deleted 2 failed login attempts by {ip_address: "192.168.178.31", path_info: "/accounts/login/"} from database.
May 18 16:08:15 fbox /usr/bin/plinth[570355]: # sso..generate_ticket(…) 

What I tried so far

Since I still have SSH and sudo access, I’ve tried resetting the password for my admin account’s password as described in the FAQ, section 3.3.8 - however those seem to be outdated:

When running the first step, I am getting an error message telling me that the user does not exist in the LDAP DB:

admin@box:~ $ sudo LDAPSCRIPTS_CONF=/etc/ldapscripts/freedombox-ldapscripts.conf ldapsetpasswd admin $(slappasswd)
New password:
Re-enter new password:
User admin not found in LDAP

Running the second step (the python script) succeeds without any issues, however login still fails with the same error as before - no change here.

I have tried restarting services plinth and apache2 hoping this would make a difference, but no change here.

Version info

  • You are running Debian GNU/Linux 12 (bookworm) and FreedomBox version 24.10. FreedomBox is up to date.
  • Running on a Raspi 4 with vanilla Raspbian Bookworm 64bit, FBX installed via apt.

Does anyone have alternative ideas how to recover my plinth admin account? I’ve seen various (very old) thread here on the forum (e. g. this one) but have not found a solution, yet.

ATM I am not able to administer my FBX using plinth, e. g. install new applications, remove others, set up user accounts. Any help would be greatly appreciated!

Thanks!
Axel

My description above was like a rubber-ducking session. I was using the wrong ‘admin’ username :man_facepalming: After a reinstall half a year ago I had changed the admin account’s handle and did not remember it correcly.

I actually found out this way:

  • Logged in via SSH with a sudo account
  • Made a backup copy of plinth’s SQlite DB: cp /var/lib/plinth/plinth.sqlite3
  • Made it user-readable chmod 644 plinth.sqlite3
  • Opened it with sqlite3 plinth.sqlite3
  • Listed all tables with .tables
  • Ran a query select * from auth_user; since that sounded plausible

The actual user names are listed as plain text there (passwords are hashed, as expected), but I saw that I was using a different user name than the one here.

Thanks for reading this far. Classic PEBKAC situation.

Cheers,
Axel

2 Likes