[SOLVED] eJabber don't run well on rpi3B and problem with DNS

Problem Description
Hi Everybody,

I wan’t use ejabber to creat a local chat server without internet for emcom.

I have installed the last image of Freedombox on a rpi. I’ve made update, etc … I’ve installed jabber with success.

My rpi is connected on my LAN as a regular client in IP dynamics and firewall configured in internal.

My problem is when I want to log with a client XMPP from a PC or via the same rpi (with client python), it don’t run. Only web App is ok. Error message says “host-unknown”.

First, I verified my DHCP server, domain name on my DHCP server and rpi, hostname in rpi. When I check in a browser, url run well and with Ping.

Second, for me, it’s a DNS issue. I decided to configure rpi as a NAT router with two network devices. Lol lol lol, DHCP of rpi don’t give any DNS address … when I I configure my PC in fixed IP and force DNS to rpi, don’t work, there is no internet.

I concluded than freedombox (last stable version) don’t work well and have a serious issue with DNS.

I decided to try to install it on a computer (Futjusu Siemens futuro S900 AMD 64 bits 2GB RAM). Boot isn’t very good, but system is up and I can join web CLI. I install ejabber. I configure firewall. And surprise, it don’t work. I have the same issue with hostname and domain.

I tell you about this for help and known if other people are same issue with DNS on router mode.


SOLVED solution here

1 Like