[SOLVED] Can't connect out of the gate

#1

Just received my FB today (4/26/2019) and followed the getting started instructions. Working on Windows 10 to try and get started.

I’ve plugged in the battery, plugged in the cable to the router, plugged in power, waited for 10+ minutes, and then tried to connect and I get nothing. I believe I see the IP it’s using in my router’s list, but I still connect with that. Pretty much stuck at this point with a box I can’t see. Any ideas?

1 Like
#2

With http://10.42.0.1/ i get a message that 10.42.0.1 took too long to respond.

http://freedombox/ tells me the server address cannot be found. same for http://freedombox.local/.

http://192.168.0.25/ also says too long to respond.

#3

Hi, thanks for buying a FreedomBox.

First off, let’s confirm some basic information:

  1. Is the SD card fully inserted into the SD port?

  2. Does your router recognize the device as a “FreedomBox”? The router should identify its name as “freedombox.”

  3. Is the computer you are using connected to the same router as your FreedomBox, or are your FreedomBox and computer connected to different routers? For example, some homes have both a modem and a router. If your FreedomBox is connected to your modem but your computer is connected to your router, then your computer might not be able to reach the FreedomBox. In this case, you’d either have to connect the computer to the modem or connect the FreedomBox to the router.

#4

SD card is inserted correctly.

Modem does not show “FreedomBox” but rather “DESKTOP-PTT8V6D” which I can only assume after several times connecting and disconnecting is the FB.

Computer is connected to the router - The unit is a modem/router unit from my ISP. Maybe that’s a problem?

#6

Let’s clarify a little further. Do you have two network devices (i.e. a modem and a router) or one network device (just one router/modem)?

If you have two devices, then please make sure that your FreedomBox and computer are connected to the same network device. This means both the FreedomBox and computer would need to be connected to the router.

#7

It’s a single device. Sorry, should have been more clear.

#8

More questions:
Ok, so you plugged in the FreedomBox to the router via ethernet and to the power. Do the green and yellow indicator lights on the FreedomBox’s ethernet port start blinking?

Also, is there a red light coming out of the power cord’s port?

Suggestion:
If you have an Android device, please download the FreedomBox app. You can use it to find the IP address of the FreedomBox on your local network. Just make sure your Android device is connected via wi-fi to the same local network as your FreedomBox (i.e. to your router’s wi-fi connection).

#9

Solid red for power. Solid green and blinking amber for network.

Tried the android app but all it shows is my Brother printer.

#10

From this, we can infer that your LIME2 is powering on as expected. But if the router is not identifying the FreedomBox, then it is possible that the OS has not booted properly. @sunil might have some ideas of what to try next.

We appreciate your patience. It’s the weekend, and our team may not be able to get back to you immediately. But we’ll do our best.

#11

Solved!

So when I was connecting things, I inadvertently bumped the SD card and it clicked out. I did catch this and re-insert it properly, but I think because the battery was plugged in, it caused an issue that wouldn’t let it boot. I disconnected the battery, waited a minute, and plugged everything in without the battery and now I see the welcome screen.

Thanks so much for the assistance and sorry for the PEBKAC issue!

Have a great weekend.

#12

This is great news. Thank you for updating us.

Best of luck with your new FreedomBox! And let us know if you have any other questions in the future.

#14

In case it helps anyone else, I have one thing to note.

I was battling my network for a little while last week because the FreedomBox (A20-OLinuXino-LIME2, stable build) was not visible on my local network using the router’s web interface, running arp-scan, etc. I could ssh to it, however. I had the same results using several micro SD cards. I later downloaded the Pioneer image and it was quickly available on the network. I’d have to check if the checksum was intact for the “non-web-interface” img file, but using a different img altogether made it a non-issue for me.