Setting up FB as router troubles

Steps that I have followed, using an older computer with three ethernet cards:

  1. Install a fresh debian buster using netinstall, only basic system and desktop.
  2. Changed sources.list to point to testing.
  3. apt update, apt upgrade
  4. apt-get install freedombox (with non-interactive settings)
    Topology as follows
    WAN <–> Wifi-Router with ethernet ports <–> FB
  5. First problem was that I could not get Lets encrypt to work, dig responds fine, using service. I can log in only via router. Second problem is the GUI, described below.
    Have tried: DMZ in router, not DMZ but redirecting ports. Tried also WAN <–> FB, but had to revert because could not get GUI working, only console (Ctrl+Shft+F2, etc), so could not log to plinth. Why, have no idea. But still could get to FB via router.
    So I connected a laptop to one of extra ethernet card 1, but can not get connection either, despite having set up FB as router. Tries to connect, but is not allowed.

Could you explain what you mean when you are able reach via router?

Let’s Encrypt will work as soon as your FreedomBox is reachable from outside, so focus on that.

Are the additional network interfaces configured as ‘Shared’ connections? Can you show the details page of those?

Also the WAN interface is not showing up in the networks list. You must have configured this with Debian (outside network manager) during network installation. But this should not be a problem since it will assigned external zone automatically.

When you try to access GUI, are you using the domain, or internal IP address or freedombox.local? Are you connected locally or via outside network?

When connected directly to the FB I can’t get GUI, only the mouse pointer appears and after a while it goes blank. Then only console while connected directly to FB. From the outside network I have not been able to connect to FB yet. I suspect that the router is part of this “not connection from outside” problem, but my hands are tied by the lack of direct GUI.

Both are internal, don’t know where it would show “shared”. Here is one:

and the other

Yes, it was configured with Debian. No idea why it doesn’t show up. However, is active, and shows as an option if I try to add another interface.

More precisely: if i log to FB from another computer connected to WiFi Router, then I connect to FB by pointing to
The other options have not worked either, that is, freedombox.local, etc.

This is due to FreedomBox security rules. You can turn it off in System->Security->Restrict console logins. After this you should be able to get GUI as usual.

Network manager (used by FreedomBox for all networking stuff) does not manage connections if they are configured manually in /etc/network/interfaces. You can comment it out, reboot and configure inside FreedomBox if you like. Otherwise, leave it there.

To configure a shared connection you need to make the IPv4 connection method as “sharing”. See this manual page for more details:

The mDNS auto discovery of hosts does not work on interfaces in “external” zone (default). Once you have your additional interfaces working (when you set them up as “shared” mode), freedombox.local will work on that.

BTW, all this should not have stopped your domain setup from working. Does your Wi-Fi router get a public IP address when you connect to your ISP?

I believe so, when I do dig it gives me in the answer an IP, Thanks, Sunil, will try that now.

How do I determine for sure if I have a public IP? My ISP connection is fiber optic, does it make a difference?

A public IP address is something that is not a private address or a link-local address. Fiber optic should not make any difference, unless there is another router in front of your Wi-Fi router that is taken up the public address and refusing to forward traffic to you. Whether you get a public address is mostly based on your ISP (some provide, some don’t).