Lets Encrypt trouble

This a follow up on a previous topic, Setting up FB as router troubles , but a different focus. Since Sunil mentioned that having the router behind the nat should not be a cause for problems, and tinkering was taking down the whole household, I put FB behind the router. I changed to an older router, thinking that it could be the problem, but still same issues. Here is a screenshot of the router that seems to tell me that my ISP doesn’t give me an external IP
Diagnostics indicates failure for Mumble

and full failure for LetsEncrypt and Networks.
I must add that I installed today COTURN, but has not helped (yet).
Addtionally, curl -4 http://myip.datasystems24.de provides an IP, same one as dig myname.freedombox.rocks, but ping myname.freedombox.rocks has 100% failure, I assume router does not respond.
Thanks for the help and time.

Hello @Ant,

Is your older router get its IP address ( from your ISP box ?

Do you have to activate some kind of DMZ forwarding to your FreedomBox ?

According to your screenshot Internet Port you get an internet address. However, you get which is considered a local address.

If you have internet, can you figure out what your real internet address is?

1 Like

I could, I did it, but still did not work

If I do whatismyip.com, or if I use the command curl as descibed above I get the same IP in both cases, 66.119.x.x

yeah, but 66.119.x.x is very different from Are you using a cable connection? Would you be willing to share your router brand and model?

1 Like

Yes, of course, it is a Netgear Gennie R6250. The fact that I am given is really bothering me.

Could the Internet Port of your R6250 router wired to your FreedomBox or other-box and get its IP ( from it ?

This ?-box seems to be a local DNS at (also).

Capture d’écran de 2020-06-05 09-28-08

We may pay attention to this below:

Capture d’écran de 2020-06-05 09-27-16

From R6250 datasheet

1 Like

About DMZ things, did you do it twice ?

  1. ISP-box -> Netgear-DMZ
  2. Netgear-DMZ -> FreedomBox-IP-given-by-Netgear

Unfortunately, I don’t know if it’s possible.

1 Like

It seems like your router supports port forwarding: https://portforward.com/netgear/ac1600-c6250emr/

The question would be if your Internet Service Provider (ISP) gives you a local address and then later translates it to a public internet address, maybe that is the reasons you are having as an IP address.

Just to confirm, your router R6250 is directly connected to the internet? You have no other router in between your internet and yourself?

1 Like

Yes, I think that this is the only explanation. Because I have tried these two configurations:
(ISP-provided-end) <–> Router <–> FB
(ISP-provided-end) <–> FB <–> Router <–> other devices
and in both cases letsencrypt fails.
And I have tried DMZ, and port forwarding in the first configuration.

1 Like

What do you want to do in general? Do want to provide a mumble server to your friends/family (extern)?

My intention is to have a private server for matrix, mumble, ejabberd, etc

I changed the router back to Linksys Smart Wifi AC1750, run diagnostics again, and this time only networks and letsencrypt fail, both completely. All others passed with green.
curl -4 and dig give results as expected; ping has 100% loss.
This router is DMZ-ed and forwards besides required ports for COTURN, since DMZ didn’t seem to do the work for it.
Configuration: (ISP-end) <–> Router <–> FB, other devices