Possibe File System Issue With My Setup

The file system of my Lime2 server is on an external SSD as discussed here.

I recently realised I couldn’t access plinth via my web browser. I could still access the box via ssh so I tried rebooting it. Unfortunately when it came back up there was no ssh access anymore and it wasn’t showing as connected to the router. I let the battery die but when I powered it up again there was still no access.

I tried browsing the SD card but my PC couldn’t recognise it. Guessing the card had died, I tried dd’ing the bootloader to a different card (as discussed in a link in the above link) without any luck. I’ve now burnt the whole image to the new card and the box seems to be working fine again with plinth, ssh and matrix all available.

The commands I used to recreate the bootloader on the new card were:

dd if=freedombox-stable-free_pioneer_a20-olinuxino-lime2-armhf.img of=bootloader.img bs=1M count=4 status=progress
sudo dd bs=1M if=bootloader.img of=/dev/sde conv=fdatasync status=progress

Is there anything wrong with the way I tried to put the bootloader on the card? I’m not sure exactly what’s going on with the file system now and I’m worried I might run into issues in the future.