Pioneer Freedombox app install failure

New FreedomBox owner. OS updated.

I have read the various threads about issues with sources.list etc, but that all looks good.

I seem to be having connectivity issues for the updates as IP are failing to connect:

W: Failed to fetch http://deb.debian.org/debian/dists/stable/InRelease Connection failed [IP: 199.232.54.132 80]
W: Failed to fetch http://deb.debian.org/debian/dists/stable-updates/InRelease Connection failed [IP: 199.232.54.132 80]
W: Failed to fetch http://security.debian.org/debian-security/dists/stable-security/InRelease Connection failed [IP: 199.232.54.132 80]
W: Failed to fetch http://deb.debian.org/debian/dists/bullseye-backports/InRelease Connection failed [IP: 199.232.54.132 80]
W: Some index files failed to download. They have been ignored, or old ones used instead.

Is this a configuration issue on the box itself or the router it is connected to? Do I need to open ports, etc?

TIA

Hello! Can you share some more information? Where did you get these logs from?

Did you SSH into your box? Do you have access to Plinth?

I believe this problem could be related to one or more possible issues. Maybe it’s DNS, network configuration, firewall, etc.

Did you run the update manually from the command line or did you use the unattended upgrades from the Plinth interface?

What steps have you taken up to now since the installation?

That is from SSH into the box. I figured updating via SSH may fix some of the update issues, perhaps.

I am able to access Plinth.

I initially ran a system update via Plinth which appeared to update successfully:

Status

You are running Debian GNU/Linux 11 (bullseye) and FreedomBox version 22.3. FreedomBox is up to date.

I haven’t been able to do much more as the apps do not install in Plinth; they appear to be installing and when I check in SSH they appear to be installing there too but installation never appears to happen.

I have pinged the failed IPs via SSH and they are successful so I am a bit confused as to where the issue is…

Pretty certain the issue is with DNS not resolving…

Stable is bookworm currently.

Perhaps this is the problem, mismatch between sources.list and your installed version.

I don’t know why the latest Pioneer image is a bullseye image, while there are bookworm images for everything else.

Tomorrow, I’ll try an install with the bookworm image at A20 OLinuXino Lime 2 | FreedomBox - Personal Server at Home plus u-boot compiled as in InstallingDebianOn/Allwinner - Debian Wiki (I have it compiled already). I’ll tell you if that works well.

1 Like

I booted successfully (but it takes a while before plinth is ready).

In plinth, I went through the following steps;

  • enter admin username and password
  • tell how I am connected to internet (behind a routeur, fixed public IP, I will set redirections when needed)
  • accept using backports (ticked by default)
  • accept doing the updates

After that (I do something else while it is busy with updates), the “about” page says I am up to date running bookworm and freedombox 23.6.2. Then I tried installing bepasty, in order to have some app, and I can confirm it works.

So I would suggest you try to do a fresh microSD card that way:

  1. dd the bookworm image at A20 OLinuXino Lime 2 | FreedomBox - Personal Server at Home (indicated as “stable”) to your microSD card (I hope you have a reader on your linux computer)

  2. compile u-boot as described at https://wiki.debian.org/InstallingDebianOn/Allwinner#Olimex_A20-OLinuXino-LIME2__rev._F_and_newer_and_Debian11.2F_bullseye_kernel or take the one I compiled according to these instructions on a Debian 12 virtual machine in Index of /share/uboot

  3. write it to your microSD card with sudo dd if=u-boot-sunxi-with-spl.bin of=/dev/sdX bs=1024 seek=8 where you replace X with the letter corresponding to your microSD card

It is probably possible to troubleshoot your current installation but I think it might take less time to reinstall from a fresh microSD card as I explained above.

I don’t believe it is an OS issue; I have booted just fine into the OS after getting the latest (Bookworm) image. The OS updates fine (I’m on 23.6.2 also) but apps still are not installing!

I get the correct response from ‘host www.google.com’ and ping 8.8.8.8 this time (which wasn’t happening before).

Am I not waiting long enough for an app to install? How long would it normally take on this device?

Thanks!

Hmm; apps are now installing. Not sure what is different with this setup.

I have changed the network this is running through which has to be the answer but the original connection should have worked but didn’t…

1 Like

However, I now have the issue that after a while I cannot access via the web. I could access via SSH and reboot (restoring the web connection) but now I cannot access via SSH either? I can ping…

Any ideas anyone?!

TIA

I’m not sure if this is your issue but I recently purchased freedombox and had to perform this small fix to get it working. See this post: Fresh pioneer installation from provided microSD card - #6 by marty_mcfly

Thanks it was working but I have since fried my board! :confused:

So I have it set up on a SFF PC now. Must say it’s a lot faster but I guess not so efficient…

Oh, yikes! Not good. I actually moved to the Pioneer/Olimex Lime2 after my mini-pc running proxmox died after 9 months. Wouldn’t boot. Motherboard just died. Make sure to backup everything, right!