Fresh pioneer installation from provided microSD card

I did a fresh Pioneer installation from the microSD card included in the kit.


  • at some point plinth said it finished the updates
  • I installed Tor, the installation wasn’t successful (no error but it was not installed)
  • I connected via ssh and saw that there were about 500 packages to be upgraded
  • I ran “apt update”, “apt upgrade” and “apt full-upgrade”, the upgrade completed (I had to say to proceed a few times but there wasn’t really any choice to make)
  • plinth was not accessible
  • after changing the default zone to “external” in /etc/firewalld/firewalld.conf and restarting firewalld, plinth was accessible and the Pioneer seems ok

Was the image shipped by Olimex changed? If not, I find it problematic that the image isn’t really ready to use any more, something needs to be done. At the very least, there should be instructions to deal wit the situation.

I am not sure whether something else on the firewall is needed but I did not manage to use openVPN as I wanted, so perhaps there is more to do than that.

I don’t know if this is your problem, if you are using NetworkManager, but check the following post.

You need to change the line
cipher AES-256-CBC
data-ciphers AES-256-CBC

Also, comment out or delete the following line if you are not using IPV6, I think:

proto upd6

I should have been more precise: I can connect to openVPN but, in spite of having the tun0 interface configured as external, I can’t access internet once connected to openVPN. Perhaps I am simply confused (that is common when I am a bit tired), I will further check.

About the change you mentioned: it would be good to open an issue to have this considered for correction.

In this thread, I am mostly worried about newcomers being unable to install the Pioneer box now that debian stable is bookworkm (I have a spare Pioneer box so I thought: let’s do testing). I noticed the pioneer installation image on the freedombox site isn’t updated. If it is the same like the image on the microSD delivered by Olimex, people will have problems.

Since there has been issues with the firewall, I am wondering whether there are other changes needed besides the default zone. I know another manual change was mentioned by others but plinth seems to work without it. I want to test it with openVPN and see, but I want to make sure I can undo it fully in order to revert to the default state.

1 Like

In the case of the Pioneer, since you only have one interface, you won’t have access to the internet unless that ethernet interface is in the external zone. I, for instance, get access to the internet on my web browsers by routing the traffic via Privoxy.

I haven’t check the Issues, but I agree.

I agree. This project looks to be in need of active contributors.

I guess there will be a nightly image with bookworm after the next update but when it will become stable… I don’t know. I think Olimex will put on their kit sd images only the last stable release.

I got a new Pioneer freedombox yesterday and flashed the latest onto an SD card and it did not work. Cockpit and any app installs did not work after I ran Software Update. I installed twice and tried numerous fixes to try to get it to work. Eventually, I narrowed in on the issue when I saw Buster instead of Bookworm in apt sources files. This post is what got me working: Issue with automatic update to FreedomBox versions in bookworm-backports.
Editing the following two files and running apt update -y && apt upgrade -y worked.

  1. /etc/apt/preferences.d/50freedombox4.pref
  • use n=bookworm-backports in the Pin line now
  1. /etc/apt/apt.conf.d/60unattended-upgrades
  • changed to n=${distro_codename}-backports

I’m guessing that this will be fixed soon when the fix gets merged.