Matrix won't start with Public Registration enabled

Good to know it’s not just me, but sorry it doesn’t work for you either. I just tried again with a fresh instance of FB in case something went wrong the first time. This time making sure my domain name was all good, valid cert installed, then installed Coturn. Still, Matrix won’t start with public registration enabled.

Maybe it is by design to decrease attack surface? However, why would that option be available at all then? Hopefully, this can be addressed soon. I wish I had more knowledge in this area.

Did you turn on “Frequent Feature Updates”?

Hi, Yes I did. I just tried a manual update as well and tried restarting Matrix server. Unfortunately, the same situation.

1 Like

It worked fine at the beginning. This bug is occuring since a few weeks.


Okay. Well, I’m happy to gather any details necessary to help T/S this. Whatever I can do within my ability.

The not-available-on-debian sounds like the issue with a dependency not being available. I encountered this when I first installed myself a couple months ago. See it here → Matrix Install Failure on Debian Bullseye - Work Around

There was a break about a month ago where a matrix update relied on some dependency and it broke on freedombox for about a day as well. → Matrix stopped working

1 Like

Thanks for that. Did an autoremove of Matrix-Synapse server, then installed the Python dependency mentioned, reinstalled Matrix-Synapse again.

As before, the installation itself worked just fine and the server started. But when I enable public registration and update settings, Matrix service fails. Also tried stopping Matrix service first, then enabled public registration again, next I started the Matrix service, but it still refuses to start.

1 Like

I’ve not (nor desired) public registration. The closest I’ve gotten is trying to federate (which went poorly, if you look up that thread).

I’ll be watching to see if someone else has a solution. I must admit I’ve not been running matrix for long.

1 Like

The same problem here.

1 Like

@Frankie This is exactly what was happening to me, because of your thread I turned off public registration and everything worked. I turn public registration on, and it started failing tests again.

Did you ever get this resolved?

looking through the issues this was a fix for freedombox 22.14…

It’s not working for me in freedombox FreedomBox version 22.15

This was the supposed fix for 22.14:

emorrp1: So, this is an upstream issue?
yes and no, yes upstream has merged a code change in develop that will incidentally fix it, but no it’s a packaging upload that caused the problem to start occurring yesterday
Fix Synapse git info missing in version strings (#12973) · matrix-org/synapse@f30bcbd · GitHub
Copying details from other channel:
Error: Synapse 1.57.1 needs matrix-common~=1.1.0, but got matrix-common==1.2.1
Fix: sudo sed -i '/common/s/~=/>=/' /usr/lib/python3/dist-packages/matrix_synapse-1.57.1.dist-info/METADATA

IT’s not working for freedombox 22.15
@johnny got any advice please?

@sunil could you guys please provide a measure of support I’m absolutely at my wits end here, and I need this project going yesterday.

@jvalleroy any advice even a little bit of directional pointing would help please. I bought 2 of your guys units.

@emorrp1 I need a resolution for this please please please just point me in the right direction.

I am in a role of responsibility. The idea to go with your guyses server was mine, and I own it. Now I dont have out of the box functionality I basically have two broken units. Love the project, and I know i’m close to it working, but I need a fix or something…

1 Like

This is still an issue for me. I’ve been waiting on the next FB update which should resolve this. My understanding is that there is indeed an issue upstream that is holding things up.

it seems like yes there’s an issue with public registration, the one gentleman told me that it’s because it’s configured to use LDAP.

I turn public registration off, and diagnostics says everything is a go. Is this also happening with your issue?

Yes. That is exactly the same issue I am experiencing, and presumably everyone else on FB V22.15.

What’s odd is element can’t seem to find my matrix server even with public registration off. I’d expect to connect, and not be allowed to join… Can you connect?

That sounds like a completely different issue entirely.

so in your situation element can connect?

Have you tried a project like this?

I have not, thanks for the recommendation.

Please answer this for me in your situation, if you run the matrix server with public registration off, can you connect to it? If so when you type in your dynamic domain in any browser what happens? does a matrix portal show itself? or does nothing show itself?

Because when I turn public registration off, the app runs but I cannot connect to the domain through a browser or the element chat program.