Matrix Install Failure on Debian Bullseye - Work Around

Problem Description
Debian Bullseye Matrix install attempt fails; following error returned-
Error installing application: Error during installation E: Unable to correct problems, you have held broken packages.

FreedomBox Ver. 22.8
Debian 11

Last Update logs report no problems.
Diagnostics report all expected services working.
Frequent Updates set.
No issues reported by apt in CLI

Steps to replicate:
Install fresh Debian 11
Ensure all needed repos are set (ie backports)
Install FreedomBox
Ensure updated to latest and all networking config set
Attempt to install Matrix

Steps to resolve:
Manually installing matrix-synapse via
apt -t bullseye-backports install matrix-synapse
(this is obviously less than ideal)
This install will start a walkthrough setup in CLI; I aborted out of since FreedomBox does this in the webgui and let the rest of the packages install.

Perhaps there was something I missed in the process?

2 Likes

great write up. I’m having this issue.

Just to clarify - when you say:
“This install will start a walkthrough setup in CLI; I aborted out of since FreedomBox does this in the webgui and let the rest of the packages install.”

aborted out - does that mean you can just close the CLI (I’m using an ssh client), and click “install” in the plinth gui?

You are quite right- that line is not clear

When installing from CLI, the installation jumped to a blue-screen interactive walkthrough for the matrix-synapse server. First screen I think asked for the domain it would be running on.
I pressed ctrl-c to exit from this without entering in any data.

I too was in an SSH session for this. After I ctrl-c to stop the interactive install, a number of other items completed download/install. Once the CLI had finished running all tasks on the above apt install command, then I went to the webgui and pressed install there.

It looks like right now a newer version of python3-typing-extensions is required in Bullseye.
For now, on a fresh FreedomBox system you can run
sudo apt-get install python3-typing-extensions=3.10*. After that you should be able to install Matrix from the FreedomBox web interface.

2 Likes

I tried that but it doesn’t work: “E: Version ‘3.10’ for ‘python3-typing-extensions’ was not found”. Please help I need to install matrix synapse.

Have you tried the steps I outlined above?
Attempting a full install from CLI and exiting out of the interactive setup, then clicking install in the webgui?

Is this a recommended way to install it? I don’t want to break anything. And are there any security implications?

I think it is, effectively, how the system is going to do it if the Install button worked, provided you skip the interactive install section started in the CLI install and instead let the webgui complete those details.

I don’t know of any security implications since the actual configuration gets done by the FreedomBox interface after it figures out all the packages required are already installed. Mine spent a minute on “install” phase, then moved immediately to post-install config. No errors, alerts, or warnings were raised and it appears so far to work as expected. Perhaps someone else with more familiarity can answer with further detail.

1 Like

I managed to install it. The correct syntax to install the python3-typing-extensions is:

sudo apt install -t bullseye-backports python3-typing-extensions=3.10*

After go back to the webinterface and click install matrix synapse. :grinning:

2 Likes

Just chiming in to say I had a similar experience to Timmy - using a premade image downloaded from the Freedombox website.

1 Like