Freedombox is dead since this morning

My freedombox is dead since this morning. I even cannot SSH into it: "No route to host
". Which update was installed last night that might have broken the system?

There is not enough information here to say with any certainty whether or not something is wrong with your FreedomBox. This error can be caused by a network change, for example.

Have you logged in to your gateway to confirm the device is connected, the IP hasn’t changed, etc?

Try rebooting the FreedomBox with the reset button on the front (middle button I’m pretty sure, you’ll need a paperclip or similar because it is so small).

My router says that the freedombox is not connected. Physically it is connected via LAN cable.
The local IP address is the same as before.
A reboot was my first trial, I tried again just now.
There was the announcement of 22.22 about 10 days ago. Maybe this migrated to backports, got updated during the night and caused the issues with the network? Just guessing.

I can take out the micro-SD card to check some logs. Which ones are helpful?

As my freedombox did not respond at all this morning, I took the micro-SD card out to search in logs but I am not sure how to do.

I mounted it to /mnt/fbox and tried
$ sudo journalctl -D /mnt/fbox/var/log/journal

but the latest log it shows is from 2022-09-08, i.e. more than one month ago.

Anyone knows how to get the same logs like when running the “journalctl” command when logged on the freedombox?

I have the same issue : according to my router, my freedombox disconnected from my network the same night as yours, around the time for auto-upgrade I believe. So I think it is an issue with this update indeed.
I am using an A20-OLinuxino-Lime2. Do you happen to use the same device ?
I think there has already been a similar issue, where a bug affected a specific revision of this board.

EDIT: the previous bug Lost all access to FreedomBox (I don’t know if it’s the same thing happening again, since the symptoms are quite generic).

These logs are in /run/log/journal/[machineID]/, although I am not sure if they are stored in between boots–I think you have to set it up explicitly if you want persistent logs.

If you are able to connect the HDMI port to a TV or monitor and plug in a keyboard, it might be helpful to try to troubleshoot, or get the box back online with nmcli. It would be good to see a few pages of sudo journalctl -r -u NetworkManager, or even sudo journalctl -r -b.

Anyone knows how to get the same logs like when running the “journalctl” command when logged on the freedombox?

By default, all the logs are kept only in memory, so you won’t be able to find them on the sd card after the machine is turned off. This was introduced to put less write strain on the sd card.

Sorry for the late response, I have been offline for some time.

What I had already done were a couple of restarts (unplugging power, plugging in again and waiting about 1 hour). Last thing I did was also unplugging the LAN cable, from my FBx and from the router and re-plugging again. And it is WORKING again.
I have no idea why, no one even was near that LAN cable.

I am using LIME (1, not the LIME2, I am one of the first adopters and those days LIME was still suited ) with SWAP on an external USB memory stick (would not work anymore with internal RAM and ZRAM.

Only Radicale is screwed up as I kept updating my todo list on my mobile devices same as on the PC, as I had done before. Probably it does not know how to merge these changes, I will do this by hand.

I will also check logs and post any findings (also if none), but that will take some days.

Just a side-note: My FBx has become such an integral part of my daily life that any outage really is an issue. I will have to think about an intermediate back-up for the time when I am trying to resolve issues.

Thanks for the information.

If I would have another disk, would it solve the problem to mount as /var a filesystem on that disk?
Without this, would there be a simple way to have the logs saved to some external location via the network?

I am asking because it already happened that the logs allowed me to find out what the problem was, so I do have interest in having them after reboot.

You can write the logs to the local sd card by going into System → Configure → System-wide logging.

1 Like