Freedombox is a wonderful idea

Freedombox is a wonderful idea and exactly the kind of home server i wish to have: The mix of applications that help to become more independent of G’'gl & company without giving up comfort

List of things I like: Privoxy, Matrix Synapse, Syncthing, Privoxy, Radicale…

Apps I liked, how they worked: Syncthing is especially important to me. It’s easy to configure and now runs on my mobile phone, laptop and desktop. One folder for photos and another. Radicale I like too but it does not work for me until now… Matrix Synapse is working fine and the Video Calls have perfect Quality. My family is spread over different country’s and Video Calls are important. That’s a good starting point. If the Freedombox is better than the usual tools, it will spread quickly

Setup experience: Very good and easy but if things are different to standard configuration like Radicale it can be difficult

I like the user interface, the clarity, coloring and structure. Nothing to change

Things I do not like: Module memory does not show me any removable devices. I’ve already read that there is a Bug but then a hint during the setup would be good. Apps i can not choose in my distribution (like coquelicot) shut be invisible in Module Apps.

Apps that I would like to see in the future: When I started looking for alternatives, I soon came to Nextcloud. There are also images for the RaspberryPi but then I found Freedombox ;-). Nevertheless Nextcloud would be a good supplement but is certainly too extensive or too exhausting for the box?

UI elements that I missed: In the system area, easier access to the log files for the security of the server I would find good.

Feedback on a problem or for improvement: I have problems with Radicale because I can not connect to the server either with Thunderbird or with Evolution and can not copy any calendar or address books to var /lib/radicale via ssh (no permission for the directory) . I’m not sure if I need to edit the config file in etc /radicale/ or not? The app is installed, service running, diagnose everything green except ip/radicale via TCP6 but if i try to connect i get a error 503 Service Unavailable :frowning:

Tahoe-LAFS wasn’t running and I made a mistake so that I do not even get on the configuration page (error 500). So my question would be whether and how to uninstall modules and reinstall…

I’m a big fan of Freedombox! But if you want the system to spread faster you have to improve the pre-configuration even more. “Normal users” like me quickly reach their limits. You all have created something great with freedombox and you are on the right track! I hope I can help you with this feedback to understand what normal users need and feel. I have learned a lot in the last 4 weeks with Freedombox. I have 9 of 11 installed apps running and working on the problems of the last 2, step by step.I am looking forward to the future versions and will do a lot of advertising for the Freedombox with my friends. My family knows my affection for open source and works beside the usual tools now also with my (much better) alternatives

all the best and thank you for the Freedombox
Greetings from Sweden, mikaelb


Debian GNU/Linux 10 (buster) and FreedomBox Version 19.1. (stable) Image downloaded from Freedombox.org, on a RaspberryPi 3b+ Firefox 68.01 Manjaro Linux 1.0

3 Likes

This is outstanding! I am so happy to hear about this use case.

Thanks for sharing this feedback. As you note, we are working on the making removable devices visible. But you’re right about what we can do in the meantime: we could insert a warning which informs users that there is a bug which temporarily prevents removable devices from appearing in the interface. This is a strategy our team can keep in mind in the future, especially if we expect that a bug will take a long time to fix.

We have been discussing Nextcloud for several months. In fact, we discussed the possibility of integrating it last weekend. Unforutnately, since Nextcloud isn’t a Debian package, integrating it into FreedomBox won’t be easy. But we are actively discussing this topic, and your feedback helps!

I don’t think I’ve ever heard this feedback before–it’s a very interesting idea. Since FreedomBox is designed for non-technical users (who wouldn’t even know what a log file is), we haven’t prioritized the interface for log file access. But this is an interesting idea.

Hm, that’s worrying. I use Radicale on my FreedomBox, and the only mail client I have synced to it is my Android phone’s built-in mail client. I used the “DAVx5” app to configure the calendar, and I had no issues. I have not tried connecting using Thunderbird or Evolution. Since I know that the Radicale server is working on FreedomBox, I’m thinking that you might have a client issue. I’ll look into this.

Right now, we don’t have a feature in the UI to enable you to uninstall an app. The only way is to connect to your FreedomBox via SSH and enter commands to uninstall the module.

I agree with your sentiments completely. You’re right that we need to enhance pre-configuration. We have quite a ways to go, and we’re extremely grateful that users like you are willing to be patient!

Please note that running this many apps at the same time on a Raspbery Pi 3 may result in slower performance. I believe that one of our developers, @sunil, once said that 6 apps is the upper limit of what he would recommend for a single-board computer. Something to keep in mind!

Thanks so much for your extensive feedback! We will consider it carefully.

1 Like

Hi again. I just tested the Radicale issue myself. I am running FreedomBox Buster v19.2 on a LIME2.

I created a new calendar in Thunderbird by following these steps:

  1. Click “New Calendar”
  2. Select “on the network”
  3. Select “CalDav” as the format
  4. Enter the URL for the specific calendar into the “Location” box
  5. In the “Email” drop-down menu, select “None.”
  6. Enter a name for the calendar
  7. When prompted, enter my username and password

After following those steps, the calendar events appeared in my Thunderbird calendar. So I am not having the same issue that you had.

A few follow-up questions to figure out what went wrong:

  1. Did you configure a domain name at example.freedombox.rocks?
  2. Are ports 80 and 443 open in your router?

Hallo, thank you for answering! Yes, the ports was open. I have started the radicale service manually via ssh on the command line.
First I checked with
sudo service --status-all
and the radicale service was off although he was displayed in the box as started, anyway now everything works fine. Also the webinterface to create the address books was accessible.
Tahoe-lafs is also back after i reinstalled the application via ssh with apt but i have a problem with the domain, seems to be 2 times in the configuration like this:
-----Die Tahoe-LAFS Server-Domain ist eingestellt auf mydomain.freedombox.rocksmmydomain.freedombox.rocks-------, i will check the configuration and
I will report when I find out something