[SOLVED] Radicale: 503 and "uwsgi: attempt to connect to Unix domain socket /run/uwsgi/app/radicale/socket (radicale) failed"

Problem Description
I freshly installed Freedombox to a DigitalOcean droplet. I also imported an existing radicale folder following these instructions.

However, when trying to access the web client (https://domain-name/radicale), I get the following message:

Service Unavailable

The server is temporarily unable to service your request due to
maintenance downtime or capacity problems. Please try again later.

This is what I see in the apache2 error log:

(111)Connection refused: AH02454: uwsgi: attempt to connect to Unix domain 
socket /run/uwsgi/app/radicale/socket (radicale) failed

AH10101: failed to make connection to backend: httpd-UDS:0

After SSHing into my droplet, I saw that the radicale service had not started, even though it was showing as green on the admin UI (this comment helped me). So I started the service manually, but still no success after that: I still get the 503 and the error I mentioned above.

Would you know what’s going on here?


  • Freedombox version: 19.1
  • Debian GNU/Linux 10 (buster) on DigitalOcean droplet
  • I installed Freedombox on the droplet via apt install.

Nevermind, it’s working now.

In addition to what I mentioned above:

  • I renamed the only folder in /var/lib/radicale/collections/collection-root to match the username I was logged in with in the admin panel
  • I restarted the instance.

I can now access Radicale Web. All good.


I’m a total n00b. May I ask you how you started the service manually? I typed systemctl start radicale.service but it asks me a password, and the password I gave to the admin acount doesn’t work.

Edit: I found, I just typed sudo su - before systemctl start radicale.service.

FreedomBox doesn’t use radicale.service though. We run radicale as a uwsgi app.

I’m not sure I understand why, but doing that made Radicale working.