Error installing apps after fresh install of FreedomBox

The FreedomBox is plugged to my router.
Bought 07.2021
Version Debian GNU/Linux 10 (buster) and FreedomBox version 21.4.4

Since I had to re-install a fresh FreedomBox on my recently acquired Pioneer Edition, I have the following error message when trying to install apps :

I tried the ssh trick and it gives me the following (roughly translated in english sorry) :

$ sudo apt update
Achieved :1 stable InRelease
Achieved :2 stable-updates InRelease
Reached :3 buster-backports InRelease
Ign :4 stable/updates InRelease
Err :5 stable/updates Release
  404 Not Found [IP : 2a04:4e42:6c::644 80]
Reading package lists... Done
E: The repository stable/updates Release no longer contains a Release file.
N: Updates from such a repository cannot be done securely, and are therefore disabled by default.
N: See the apt-secure(8) man pages for repository creation and user configuration details.

For background, the first time I used the FreedomBox I think the power was turned of during the update and I was not able to access it afterward. so I had to re-install a fresh one using this image.

On the Update page I have this message :

When I try to apply manual update it fails.
You can see the log HERE.

It looks like our Pioneer image was built using “stable” rather than “buster” (which was stable at the time). However, now “stable” means “bullseye”, and the required format of the security line has changed.

My recommendation is to wait for a new Pioneer image based on bullseye.

OK thanks.
So there is nothing I can do right now to make this bad girl (yes my FreedomBox identifies as a girl) work again?

How long can this take ? I can wait but my FreedomBox is useless as it is for the moment.
Can’t I just build the image myself using Freedom Maker ? (I’m not so techie but it could be a fun learning project).

Just found this post FreedomBox 21.7 released so I guess I have to wait for the new image being published.

Upgrade to Bullseye

1 Like

(When) will there be a Pioneer image based on Bullseye? And where to find it?

1 Like


I don’t know. I think (hope) soon :relaxed:


Maybe here and you can build it yourself using Freedom Maker.

I have some troubles installing Freedom Maker on my Mint 20.2 right now when I come to this point
$ sudo apt build-dep .
I got the following error (roughly translated in english for your convenience)

The following packages contain unmet dependencies:
 builddeps:. Dependency: debhelper-compat (= 13)
E: Unable to fix problems, faulty packages are in "keep as is" mode.

I don’t really have take the time to dig it more lastly but I keep an eye on it. I think I will just wait for the image being published.

This must be merged for freedom-maker to be able to build stable images for Bullseye. freedombox-team/freedom-maker!212

1 Like

Same thing for me. Literally got pioneer, new, a day ago and can use no apps. Tried ssh’ing in outer 2019 glitch instructions but it did not have the yes prompt and still did not let me.

New image published today here
Thanks !

1 Like

Hi! I had a similar issue.

I had just installed FreedomBox in my home computer (Linux Mint 20.2) inside VirtualBox using freedombox-stable-free_buster_all-amd64.img.xz (unpacked, then used VBoxManage convertdd freedombox-stable-free_buster_all-amd64.img freedombox.vdi to get a usable .vdi disk). All run without issue.

However, when I tried to do updates (sudo apt-get update) in the terminal I got the response below:

Hit:1 stable InRelease
Ign:2 stable/updates InRelease
Hit:3 stable-updates InRelease
Err:4 stable/updates Release
  404  Not Found [IP: 80]
Hit:5 buster-backports InRelease
Reading package lists... Done
E: The repository ' stable/updates Release' no longer has a Release file.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.

Upon closer look, it seems that the content of /etc/apt/sources.list is no longer valid. stable/updates should read stable-security. So, where it reads:

deb stable/updates main
deb-src stable/updates main

it needs to be changed to:

deb stable-security main
deb-src stable-security main

After this change, I was able to run updates. Perhaps the freedombox-stable-free_buster_all-amd64.img.xz file should be updated to fix this?


1 Like

All the newly built stable images (announcement pending) seem to have bullseye-security listed in the sources.list. So, there is no problem there.

It is also best if users use bullseye everywhere in the sources.list instead of stable to allow FreedomBox to automatically upgrade to next stable release bookworm in 2 years in controlled manner. A typical sources.list file should look like:

deb bullseye main
deb-src bullseye main

deb bullseye-updates main
deb-src bullseye-updates main

deb bullseye-security main
deb-src bullseye-security main

deb bullseye-backports main
deb-src bullseye-backports main

This has been handled in the latest batch of stable images for Bullseye. So, this problem wouldn’t be repeated during the upgrade to Bookworm in 2 years. Maybe FreedomBox can make the necessary changes on existing systems meanwhile.


Yikes, I just had a rolling brown out a week back and it destroyed three MicroSD cards and two hard drives (they where from old laptops anyway, all data was backed up to separate machines with synching and Nextcloud on windows so no colossal loss) in three different RPBI servers (2x RBPi 4, 1x RBPi 2). I cant get open VPN on my stable one. Ill need to update my sources. Will previously running FreedomBox stable instances auto update soon to match your new stable image?

Yes they do, but you might have to wait a day or two for the auto-update to kick in. If you’re installing on new microSD cards, I’d recommend installing the stable images for Bullseye and then restoring from the backups. You can get the images from the respective download pages on the website.

As far as I know, both the images are tested and reported to be working.

1 Like

Awesome, thank you @njoseph . I just got the VPN installed and everything seems to be working and connecting (server → port forwarded → internet → devices on another network). The VPN client connects but I can’t get internet along with access to local services. If I can’t get it working, I’ll open another issue next week. But hey, at least it can install (with manually updates sources) and generate an open VPN profile.