[COMPLETED] Anyone has a Raspberry Pi 3B+ and willing to help some testing?

We have recently received a report that FreedomBox stable and testing images are not working on Raspberry Pi 3B+. If you own an Raspberry Pi 3B+ and are willing help with some testing (about 30mins of effort), please participate in this bug: https://salsa.debian.org/freedombox-team/freedom-maker/issues/164

To help, please follow the instructions from video at https://freedombox.org/ or from https://wiki.debian.org/FreedomBox/Download and download stable/testing image for Raspberry Pi 3B+, write it to SD card and see if FreedomBox web interface is available after booting.

Thanks in advance.

1 Like

I have a Raspberry Pi 3 and 2B. I think the other images are also broken.

What I experience is after having inserted the SD Card into my Pi (either 2B or 3), the boot sequence seems to be stuck at the very beginning.
I saw that the /boot folder is empty. Is that OK?

How can I help to get this fixed.

I have a Raspberry Pi 3b+ and run the stable image. I have in use:
Radicale, Deluge, Ikiwiki, Matrix Synapse, Syncthing, Privoxy, TT-RSS, Infinoted, Searx, Roundcube.
Not all of the other apps work and I have not tried them all yet, but the above apps are good for everyday use. Never had a Problem under Booting

Hi MikaelB!

I tried both stable and unstable images for 2B and 3 this week and none of them booted.
I simply extracted the images and used ‘dd’ under Linux mint to put the image on my sd card. Did I miss something?

Please be sure that you are not expecting boot messages on the monitor. No messages will be printed beyond ‘Loading kernel…’. You need to connect to the machine using network and web interface. See: https://wiki.debian.org/FreedomBox/Hardware/RaspberryPi3B+

You are probably looking at the wrong partition. There are three partitions. The last one is the primary / partition with empty /boot folder. Second partition contains the /boot folder contents.

Since earlier images worked, if you have downloaded the stable image at an earlier date, that image will continue to work. Please set aside the SD card you use for production and try downloading and running latest stable/testing image.

I do not have a monitor connected. I expected a web interface or access via SSH. But the freedombox does not show up on my router. Is that correct? Also the green light (SD Card read access) )on my Pi only flickers within the first second after booting up. Than it remains off.
Is there a serial UART which I can connect to?

I understand.

That looks correct. You can connect RPi to a serial cable with a regular serial USB connector. See https://elinux.org/RPi_Serial_Connection .

The bug report has some more information from another contributor. So far, since we have confirmed that Linux kernel has been loaded by the boot loader, we can likely rule out problems with u-boot, Raspberry Pi firmware and u-boot’s boot script. There are logs posted in the bug report after the failed boot from SD card. I haven’t looked at those yet.

Another step to debugging would be print the kernel message and watch them on serial console. One will need to mount the SD card on a different machine edit the file /etc/default/flash-kernel and edit LINUX_KERNEL_CMDLINE="quiet" to LINUX_KERNEL_CMDLINE="" and then run the flash-kernel command. Let me know if you want to do this, I can provide more information how to do this.

I have today downloaded a fresh stable Image for Raspberry Pi 3b+ form Freedombox org and flashed with balena etcher to a other SD Card. Boot successful, after booting there was a automatic Update to 19.14 and reboot. Than created a user and installed cockpit, all fine. I have no Monitor connected, can output from dmesg be interesting or something else?


For the freedombox-testing-nonfree_latest_raspberry2-armhf.img image running on a Pi2Bv1.2 I recorded the following via serial line:

➜ more kernel.out
U-Boot 2019.01+dfsg-7 (May 14 2019 - 02:07:44 +00>�)>

DRAM: 948 MiB
�MMC: sdhci@7e300000: 0
Loading Environment from FAT… *** Warning - bad CRC,"using default environment

mbox: Header response code invalid
bcm2835: Could not configure display
In: serial
Out: vidconsole
Err: vidconsole
Net: 8 CACLE: Misaligned operation at range [3b3cb528,03b3cb540]
CACHE: Misaligned operation at range [3b3cb528, 3b3cb540]
CACHE: Misaligned operation at rqnge [3b3cb528, 3b3cb540]
CACHE: Misaligned operation at range [3r3cb528, 3j3cb540]
CACHE: Misaligned operation at range [3b3cb528, 3b3cb540]
CACHE: Misaligned operation at range [3b3cb528, 3b3cb540]
CACHE: Misaligned operation at range [3b3cb528, 3b3cb540]
JCACHE: Misaligned operation at range [3b3cb528, 3b3cb540]
CACHE: Misaligned operation at range [3b3cb528, 3b3cb540]
CACHE: Misaligned operation at8range [3b3cb528, 3b3cb540]
CACHE: Misaligned operation!at rangu [3b3cb528,(3b3cb540]
CACHE: Misaligned operation at range [3b3cb528, 3b3cb540]

Am I doing something wrong? Because the Pi3b+ image seems to do it…
Hava nice weekend! Hendrik

This is good to hear. This essentially says that the either other reports were incorrect, or that the bug resolved itself. Another possibility is that issue only occurs on sometimes (less likely).

Thank you for the report. Judging by the partially missing text, perhaps the serial connection was not made properly. Please check a few things:

  • 5V wire should not be connected.
  • Ground wire should be connected.
  • Also verify the parameters such as a baud rate and parity bit that you set on the tool used to connect to the serial terminal.

Also were you able find the device on the network?

Could you please try to test the testing images in the same way? Over at the bug report, we have at least one report the testing images were not working.

I have today downloaded a fresh testing Image for Raspberry Pi 3b+ form Freedombox org and flashed with balena etcher to a other SD Card. Unfortunately, I did not get this image booted

Hello I am French and I am using a translator.

I have a rpi 2 a rpi 3 and rpi 3b +. I have each time installed different freedombox images. Right now rpi 3b + is with the image testing and boot on ssd. What I noticed is that if I unplug the rpi (power failure) and I reconnect it, it will not restart. But if I unplug and reconnect a second time he will restart and operate. Whether on a micro-sd boot or a boot ssd.



Sorry for the delay. The device never showed up on the network.
I tried testing last week but it did not boot.

Any hints?



So, i wanted to setup Freedombox on a Pi 3B+ and failed. i found this thread and thought i would help.
I checked the boot process of the Freedombox image and i triple checked that everything is fine (also booted Raspbian and read the serial console output which was fine).
I wrote the image with dd and Etcher. No matter what i do, i can’t get it booting and the Serial Output is garbled.

I have 2 Logfiles i created with Putty. A clean raspbian Buster boot and the garbled freedombox boot. I used a CH314A to read the serial console.

If you want the Logs let me know.

1 Like


Hello, Christoph! My name is Danny, and I work at the FreedomBox Foundation. I noticed that you’ve made your first contribution to our forum. Thanks for offering to help with this issue with the RPi3. And welcome to our community! Since you’re new, I want to make sure that you know about all the resources and support we offer our contributors. Check out our Welcome page for all the basic information about contributing and for the contact info of our core team: https://wiki.debian.org/FreedomBox/Welcome

I’m very happy to see that you’re interested in getting involved in our community! If you have the time, please do join one of our upcoming weekend progress calls and introduce yourself. We’re all here to help you, so don’t hesitate to reach out to members of the core team!

Hello @hhanff, @MikaelB, @bibibox, @pythoner,

My apologies for not attending to the issue in a while. I analyzed all the information so far and summarized:

  • Stable images are working well as noted in the bug report. Testing images are not working.
  • Even with testing images, it has been reported that booting was successful. This report talks about not using Ethernet but connecting via HDMI cable. When logs were analyzed from this successful boot it showed everything to be normal. This report did not include logs from serial console.
  • @pythoner sent me boot logs collected with FreedomBox and with Raspbian using a serial cable. It shows completely garbled output for FreedomBox image. This could be an issue with the serial setup. Or it could be the reason why things are not working as expected. If so, the failure must be at a very early level possibly in the firmware or u-boot.

Thank you for all the help so far, I will keep looking.

Update: @pythoner actually has tried multiple times with the FreedomBox image and every time the logs in the serial console are garbled. This indicates a problem with u-boot or the firmware we are using.

I’ve just received my RPi3B+. I installed as per instructions (dd’d to sd card on MX linux and calculate Linux).

  1. Stable does not boot, red (power) light on, green light stays off.
  2. Booted into raspbian to check if board ok. All works fine.
  3. Installed testing. Boots - yay. one eth light flickers. cannot connect from laptop. HDMI display first line: eth net not found, then boot with one FAIL: entropy (something)

Have read that old image still works, it there one available for me to use?
How can I help to get this working?
I will try a nightly cos I need something to work! and report back.
If you need more info please ask.