Cockpit server administration

I’m in the same “blank screen” boat. 1) I’m using oracleatbelfry dot com as the domain 2) the cockpit page from “sys” lists two addresses, an onion address as well as oracleatbelfry dot com 3) I can enter https colon slash slash oracleatbelfry dot com slash _cockpit into my linux desktop’s browser and it goes to the cockpit login screen as you’d expect 4) but I still get the blank screen.

Sorry to hear that. I gave up and mine is sitting on a shelf. If you find an answer, please share on here. Thanks

1 Like

I installed FreedomBox about a week ago and I had the same problem. I worked on it until I was cussing. :face_with_symbols_over_mouth: Figured I’d give it another go because this entire concept is just awesome to me. One question is… I’ve seen several articles that .local was actually sold by ICAN or whoever it is and that some bonafide corporations are actually using that domain now. Is it still ok to put .local in for a private domain name or should we use something else? I’ll probably register a domain at some point, but if this box is “for the people” and for beginners, most standard users don’t even know what a domain is and their eyes will glaze over if you try to explain it to them and they SURE aren’t going to register one. Anyway, I’m reinstalling and will give it another shot, I just wanted to chime in and let y’all know that mine wasn’t just a drop-in install. :slight_smile:


.local should work ok. Is it listed on /plinth/sys/cockpit/ under “Access”?

I just got FreedomBox running on a VM on my home network. For me, this error seems to be related to access configuration. Like as soon as it hits the browser’s content sec pol for wss://, nothing further processes.

My domain is and I’ve got all of the necessary ports forwarding. Cockpit loads fine in Chrome and Firefox, but when I load Cockpit in Safari on my Mac, I get the following in the web console:

1. Failed to load resource: the server responded with a status of 404 (Not Found) (nav.css, line 0)
2. Refused to connect to **wss://** because it does not appear in the connect-src directive of the Content Security Policy.
3. SecurityError: The operation is insecure.
	(anonymous function) (cockpit.js:380)
	t (cockpit.js:380)
	je (cockpit.js:577)
	(anonymous function) (index.js:72:52269)
	n (index.js:1:115)
	(anonymous function) (index.js:40:87529)
	n (index.js:1:115)
	(anonymous function) (index.js:1:904)
	Global Code (index.js:1:914)

I got lost in the weeds somewhere, but just thought I’d kick back in… I haven’t configured a permanent freedombox yet, but will soon. I’ve installed it 3 or 4 times now on various setups and cockpit worked fine on a couple and I got only the white screen and you couldn’t do anything on a couple. I don’t remember which ones were which and I know that’s not much help, but just wanted to report back on that for what it’s worth.

Sorry, I never answered this… yes, the correct url shows up under /plinth/sys/cockpit under access. My problem just turned out to be going to the IP instead of the full name as mentioned in the docs. :slight_smile: If I try to go to the ip address, I get the white blank screen, if I go to the proper hostname.local, it loads up ok for me.

I’m actually right there with you. After about 30+ clean installs, several configuration changes, lack of support on the forums, and an issue that has apparently existed since Jun of 2019 (1 and a half years and this isnt resolved? What?), i think its time to call it quits. I’m very disappointed with my purchase of this coffee holster. Since I thought this would be a product that would work out of the box, since the debian committee endorses it, but unfortunately, it looks like this OS is hampered with a severe lack of development and support. I just dont understand why this issue isnt publicly disclosed on the olimex website. I mean, having to use tor browser just to be able to log into cockpit just sounds absolutely obsurd to me. Thats like having to use the tor browser to log in to my own router. I would give this a second shot if the developers reached out to me and explained how i could properly configure cockpit to work with any browser other than tor, but i’ve made several unanswered posts here since i got the box, and it really seems like nobody cares very much, or there is just a real lack of support in the community. I was contemplating even helping with development, but the fact that nobody responds to my simple posts, makes me think that it would be an extremely frustrating experience if I put time and effort into the codebase, and the devs dont get back to me, or it takes them weeks to respond. So i’ve tabled that idea as well for now. The olimex forums are just as bad if not worse here. I wish I knew all of this before I bought my electronic coffee tray.

Refreshing the page in my browser doesnt work no matter what browser i’m on. Ive tried every suggestion in this entire thread (on top of about 30 clean installs), all to no avail, with the exception of enabling tor, and accessing cockpit over the tor browser. I’m about to turn my freedombox into a coffee tray, because my patience is running pretty thin. But if you have any other ideas or suggestions, or know of anyone who would be able to helpw me work through this issue, I guess i could pick it back up again for one more try.

I tested cockpit app on both stable and testing containers today. I was able to login in using Firefox and Chromium.

I have a FreedomBox installed on Debian testing and a FreedomBox Pioneer. Cockpit works on both of them.

Cockpit only allows you to login using the domain names it’s configured with.
Are you using one of the URLs listed under the Access section in the Cockpit app?

This is how it looks on my FreedomBox.

1 Like

Where, exactly is that Access section located in the Cockpit app interface?
Here is a picture of my Cockpit interface:

I have the same problem, only I have not figured out yet where I can change that setting…

It’s in the FreedomBox web interface under System -> Cockpit

Path: /plinth/sys/cockpit

Maybe the freedombox interface could also show that. Explaining that IPs are scanned more often, or whatever the reason is.

Agreed. Mine only answers to my domain url, and my pagekite url.

rasp pi4 8gb
unfortunately cockpit server does not work. blank screen , reload the page not work.

Use Tor browser.
Use Tor browser.

Hello @eboelens

Enable Tor on your Feedombox, then use your Tor address to visit the cockpit server. Using your Tor address in Tor browser.

Find your Tor address on Freedombox at: https://freedombox.local/plinth/apps/tor/

Regards: peter

sorry, my domain was not installed correctly
it works now.
I have another problem now, I’m posting a new topic

also I use a Raspberry PI4 instead of a Pioneer

Hi I gave up with rpi4 , cockpit finally worked after the correct domainen fill in. However, there were more problems outside cockpit and my knowledge is too small to put all that right. With the Pioneer freedombox it goes fairly smoothly. anyway thanks for the info