Cannot install apps or login with ssh

Problem Description
After many months of attempting to flash my own Freedombox build on a Raspberry Pi 4B without any success and without any helpful support, I finally caved and just bought a pre-built Freedombox from the website (Olimex). The initial boot gave me a lot of trouble with broken captchas and locked my Admin account. After trying different browsers, different computers, and setting a static IP, I eventually got logged into the web interface.

HOWEVER, I am unable to install ANY applications. Every single time, I receive this error:

“Error installing application: Error during installation E: dpkg was interrupted, you must manually run ‘sudo dpkg --configure -a’ to correct the problem.”

Using the command line in Windows and the Terminal on MacOS, I attempted to login via ssh and always receive this error: “Permission denied, please try again.”

This denial occurs whether I use the user@hostname.local or user@ipaddress format, and no matter which user I try. I tried creating a new admin user, disabling all privacy/security restrictions, changing the password, rebooting everything, etc., just to be sure.

So, in summary, I can login via the web interface but it doesn’t do me much good because I cannot install any apps and I cannot login via ssh to fix it. That means I am now the proud owner of not one, BUT TWO $100 bricks that were supposed to be Freedomboxes.

Y’all, believe me, I am THE target audience for Freedombox - a privacy-oriented creative type with a low budget and very limited technical skills trying to serve my community. I believe in this project and I REALLY want it to work. But if it takes a computer science degree to even get to a functioning GUI, I can assure you this will never be widely adopted.

Thanks in advance for any guidance.

Expected Results
To be able to install apps on the Freedombox.
The be able to login to the Freedombox via ssh.


  • FreedomBox version 19.2
  • Hardware: (Olimex)
  • How did you install FreedomBox?: bought pre-installed hardware

@danielcclay, please try the following approach and let me know the where exactly it fails:

  1. Create an SD card with the FreedomBox image for Olimex hardware: Use these instructions for downloading and writing to SD card.
  2. Insert the SD card and restart FreedomBox device. Since, Pinoeer has a battery, need to press the reset button or disconnect and reconnect the battery. After that follow the instructions here to get to the web interface:
  3. Complete the first wizard and create an admin account.
  4. Leave the box for a couple days and let is upgrade to the latest version which is 21.0. Confirm this in the Help->About page.
  5. Setup a domain name for the box and use that to login to Cockpit application (with web-based terminal) to get a remote shell. Note that only URLs listed in the Cockpit app will work and IP address based URLs will not work. Only admin accounts work and not just any accounts. You can also try to login via SSH. Again only admin accounts work.

Notes on problems you faced:

  • Latest version FreedomBox will automatically run ‘dpkg --configure -a’ before trying to install package. So, you won’t have to run it on a terminal.
  • SSH will fail if you try to login without admin account.
  • SSH will lock you out for sometime if you have tried to login too many times with incorrect credentials.
  • Cockpit will only work with the URLs listed in the Cockpit app page and won’t work with IP address (due to security settings).
  • It is not possible to brick a Olimex FreedomBox hardware. You can always recover by writing a fresh SD card.
  • ‘dpkg --configure -a’ related problem typically happens when you restart the machine while package installation or upgrade is running.
  • Many problems have been fixed over a period of time, but Stable release only upgrades to latest FreedomBox version with fixes only after a couple of days. A new stable release is due this year that will ship with the latest FreedomBox by default.

Hope this helps. Following the above process, let me know where exactly it failed for you, I will be able to help better.

1 Like