Cockpit doesn’t work in IOS

Cockpit works if you run it in Ubuntu, and it doesn 't work if you run it in IOS: only white screen.

What is the url used to access Cockpit? Is it the same in both the cases?

Yes. Same address.

It must be the browser that is causing the change in behavior. Would it be possible to see the developer console of the browser for error messages when then white screen is appearing?

To do this, I have to connect IPad to Mac, but I don 't have Mac.


It might be good idea to report this to upstream Cockpit project: There seems to be an issue already discussing this

BTW, do you see the white screen after login or even before that?

The login page is fine. Then there 's the white page.

I have tried for over a month to get cockpit working. I have done many many reinstalls and just the white screen.
If I manage to get to the Debian Server Login Screen I put my credentials in and I am unable to log in using my original login. I typically am using my iPad Pro however I have tried my MacBook Pro and I think I tired my windows 10 pc as well.

I keep waiting for a new version of Freedom Box firmware. I did try the weekly version a couple of times.

@atomicboy, have you tried this combination?

  1. Firefox/Chrome browser
  2. Access Cockpit using a domain name (not using IP address). The URL should be listed in the Cocpkit app page of FreedomBox.
  3. Login as admin user.

Thanks for the response.
Yes I tried Chrome, Firefox and Safari.
I did setup a domain name numerous times and it reverts to the IP address. When I get the white page I try inputting the domain in the browser and I get a Debian server login page that does not work with my admin login.
As per above… Admin login does not work.
I have tried multiple reloads of Freedom Box. Same thing every time.
I have been at this for close to 2 months.
I can SSH in but the idea was to use a simple device to learn on.

@atomicboy, I understand the pain. Let’s us try to find the issue.

  • When you try to login with admin account, do you see white page or accessed denied error?

Could you try the following:

  • Login via SSH, set the password for ‘fbx’ user and try to login with that user. Are you able to login to SSH using this ‘fbx’ user?
  • Create a new user from FreedomBox with ‘admin’ permission and try to login with that user. Are you able to login to SSH using this user?

Hi and thanks for your offer of assistance.

A month ago I was getting the white screen. More recently I have been getting the Debian Server Screen. When I try to log into that screen it fails.

I note that the browser address bar shows

If I input I get the Debian Server Login Screen again.

When I login using SSH I am able to use the credentials I setup the account with.

I am sorry but I am not following how I set the password for ‘fbx’ and then login with “fbx”. Can you please be more specific. Is this done in the Freedom Box Users App or in SSH?

Thanks again.

So here is where I am at now.

When I launch the Cockpit app I get this and my credentials do not work.

When I put
In the browser bar i get this and it does not accept my credentials.

1 Like

Cockpit is known not to work with IP address. So, ignore the results of this and focus on using the domain.

I forgot to write about this in my earlier post. Essentially, there is always a user called ‘fbx’ in a FreedomBox. This user is disabled by default but setting a password for it makes it usable again. After logging in as an admin user to SSH, you can run sudo passwd fbx to set the password for that user. Then you can try SSH and Cockpit login with that user.

As @wind wrote, there seems to be a problem with Safari browser and Cockpit. We can deal with this separately. Could you instead try Firefox on a Desktop? Don’t forget to try ‘fbx’ and a newly create ‘admin’ user. Also post about what you get when the login fails: white screen or access denied error.

When I try with Firefox on my windows 10 PC I get the white screen and refreshing it does nothing.

I have used SSH to create a password for FBX and in SSH I have logged into the FBX user profile. I do not know how to login to Cockpit in SSH.

I am at the “fbx@freedombox:~$” prompt.

Login to SSH is merely to ensure that the account is working properly. Simply use the username ‘fbx’ and the newly set password on Cockpit login page. Also, do you see the url in the ‘Access’ section on the Cockpit app page of FreedomBox web interface?

I tried using fbx as a login along with the password and it does not work. after a number of attempts I get the captcha.
I will go in via SSH again using fbx and see if I can get in.

I went in via SSH and redid the sudo passwd fbx twice changing just the password but I am unable to log into my Freedom Box.
I used a direct connection to SSH into the Freedom Box and I can login using FBX.
I have tried using the fbx profile on my win10 PC, my MacBook Pro and my iPad Pro. the fbx profile is not recognized on any of them but i can log in with my original username.

I forgot to mention that the User App in Freedom Box does not show the fbx user and I cannot create the fbx user as it is reserved.