Battery required to keep my FreedomBox running

If I disconnect the battery, after about a day I can no longer access my box (locally or from the internet, neither with a URL or ssh; however, I believe I can ping the box). To get it back online I need to unplug it and plug it back in.

If the battery is plugged in, the problem seems to disappear.

I purchased the FreedomBox pioneer edition (it’s a beautiful object, by the way, well done) probably about a year ago and have been running it with the battery attached almost the entire time. If I recall, the problem did arise the first few days of use before attaching the battery, but I cannot confirm that now. Nevertheless, I think this problem is why I attached the battery in the first place.

Does anyone else experience this? Any ideas about the source of the problem? Could something at the hardware level be broken?

Running Debian Bullseye and FreedomBox version 20.12.1. I downloaded the image from the website and copied it to the sd card myself.

With the battery plugged in, I hadn’t had any problems for the past several weeks – until two days ago.

In the past two days my FreedomBox Pioneer Edition has become inaccessible twice (no local access, no ssh, ping did not work). To get it back online, both times I unplugged my FreedomBox, let the battery power run out, and then plugged it back in. (I was too lazy to open the box to manually to unplug the battery, and I was unsure how to use the hardware reboot/shutdown buttons.)

Which log files may help me figure out what is going on? This issue is maing my FreedomBox unusable since access is too unreliable.


newbie here… have had pioneer-fbx for a year or two, mostly unused… tried it again past couple-months and have (like you) been having weird issues with the battery… specifically, it “used to” just work fine plugged in - but recently (days?/weeks?) it has been causing issues if i plug it in…

namely, i unscrew/unplug-battery so i can do hard-resets more-easily while i am changing things… once everything is working-as-i-want-or-need, then i go back and plug the battery in to call-it-done… power-it-up and now the fbx wont work (specifically, it doesnt seem to come back online correctly)…

at this point, like you, i would appreciate knowing what log-files are available to help me sort out what is going on… i have been heavy-duty tinkering, however, so ive just been leaving the battery unplugged for now while i keep doing my tinkering… your message has made me feel better about my tinkering - in that it might not be completely my own fault (about the battery-issue)… :blush:

gl, h.

ps - like you, also, there might be a hard-reset button to push but i dont know what/where it is yet… also, my tinkering was to add a sata-drive so i was wondering if maybe the current-draws were causing issues - but im still not even using the ssd yet… i have so many different issues going on right now i would start several different topics - but just, again, wanted to say thanx for posting your notes… sigh…

pps - since ive been doing manual cmds of “sudo apt update; upgrade; autoremove” im fairly sure im on the latest/greatest - but maybe i should start over with a clean-slate again (sd-card-wise)…

Did your router perhaps reset? It happened to me.
In such case the right way to go is reset the FB as explained here.