Zoph Failed Requirements

Problem Description
Zoph web client fails to launch.

Steps to Reproduce

  1. Install Zoph
  2. Click button to launch client

Expected Results
user interface

Actual results
(I get an error with the following message:)

  1. Zoph has not yet been tested against version PHP 8.2 and later. Feel free to report a bug if you run into problems
  2. max_execution_time is set to less than 60 seconds, this may not be sufficient for resizing large photos.
  3. upload_max_filesize should be 8M or more (16M or more recommended).
  4. post_max_size is set to less than 16M, this may not be sufficient when uploading large photos or archives.
  5. Not all requirements have been met. Zoph cannot run. Please fix the issues above and retry.

(a screenshot of the screen/webpage when the problem was shown)


  • FreedomBox version: 23.20
  • Hardware: pioneer
  • How did you install FreedomBox?: ‘bought pre-installed hardware’

i changed in /etc/php/8.2/fpm/php.ini according to the recommendations and it works now. Until there is a better way as a temporary workarround.


It worked thanks!
(after a reload)

sudo service php8.2-fpm reload
1 Like

Hey, as a newbie could you help me with this!? What exactly should i change in that file? And, do you access it from SSH? I was trying to look for a way of installing LibrePhoto on to the fbx but could not find info so im gonna give Zoph a try! Thanks in advance!

Hi Kuma,

Let me point you in the right direction…

  • Install Zoph from the FreedomBox apps page.
  • Follow the Zoph link from FreedomBox with your web browser - you will get the Failed Requirements page shared by @Gareth.
  • Look at the requirements which refer to php.ini
  • Log in to FreedomBox by SSH.
  • As an ordinary user read the file mentioned by @MikaelB above. You’ll see configuration keys in the file which match those referred to in the Failed Requirements list. Look for the php.ini entries from Failed Requirements and find these in the configuration file. max_execution_time is an example of that.
  • As root you’ll need to edit that file and update the values. For example:
    – find upload_max_filesize and change the value from the default 2M to the recommended 16M.
    – repeat this for all of the php.ini warning or error keys in the Failed Requirements
    – You won’t change the PHP version - just run with what you have. They are telling us that is working.

Then do the command @Gareth shows and let us know how it goes.


Thanks a lot! Everyday i fall more in love with the FOSS community. Have a nice day!


There is now a merge request fixing this issue: zoph: fix failing requirements (!2437) · Merge requests · FreedomBox / FreedomBox · GitLab


Good news, @nbenedek. Will a user having modified their php.ini file need to take any action after this correction propagated by apt?

No further correction should be expected.