Yellow Blinking, No Connection

Problem Description

The light on my FredomBox is blinking yellow and has no network connection.

Yesterday it worked fine when I unboxed it and started it. I decided to not go through the setup process and shut the computer down. As it was very late.

In the morning I connected the FreedomBox, but was unable to access it. I realized the led is blinking yellow and the ethernet connection does not show any sign of connection (no leds blinking).

Steps to Reproduce

  1. Unbox it (do not put the battery in).
  2. Start It.
  3. Wait for 10 minutes.
  4. Remove the plug.
  5. Wait for some time.
  6. Plug it back in. It does not work.

Expected Results

Setup phase should survive a new start.

Actual results

Setup does not survive a new start.


I used the wrong power cable to connect to the FreedomBox. I had more than one round cable on the table. However, I still do not know what the yellow blinking means.

Typically, the entire setup process in FreedomBox is designed to be ‘idempotent’. If setup process is rerun, it does not ruin the work already done and produces the same result as the first run. Also the setup process is marked as complete only after all the steps are completed. So, powering down during setup process should, in theory, be safe.

If you are able to collect and post the logs for the FreedomBox service, that should help us isolate the problem. Please run journalctl -u plinth and post the logs. Thanks for the detailed report.


@sunil thanks for your explanation. However, I was not able to even boot the FreedomBox, because I put in the wrong power plug. I had one on my table for an external harddrive and plugged that into the FreedomBox. It took me a while to understand my mistake. My advice to readers would be to switch on the light cross-check the plug, if you encounter the same issue :wink:

My only remaining question is, what does the yellow blinking actually mean? Maybe Olimex knows the answer to that.

1 Like

Olimex folks would certainly have answer. Please try contacting them. If you get an answer, we can document that.

1 Like

I asked in the Olimex forum about the yellow blinking:

What I gathered so far is:

  • Red LED means power is on. The Red LED is controlled by the hardware (board)
  • Yellow LED is controlled by the user (operating system).

However, until now I was unable to figure out where to lookup what the yellow blinking pattern, I saw, means exactly.

The information I am searching for must be somewhere in the kernel or the operating system (Debian/FreedomBox).

See if you find LEDs in /sys/class/leds/. This is the location for LED driver in the Linux kernel.

1 Like


thank you for pointing me to the LED driver documentation of the Linux kernel. I got a similar answer in the Olimex forum.

1 Like

I’ve also already seen that type of error under the desk…
…were so happy that I didn’t fry and smoke up that brand new thing. :joy: