X86 (amd64) bullseye stable image won't boot from USB

Problem Description
I want to install Freedombox on my x86 64-bit PC but cannot boot it from a bootable USB drive. The drive is not visible on the boot menu so cannot be selected as the boot device.

The same USB drive is bootable on my laptop so I do not think there is anything wrong with drive or its contents. Further, I have tried with multiple USB drives from different manufacturers and they all display the same behaviour.

I can boot Debian from a bootable USB drive on the PC so I do not think there is anything wrong with the PC’s ability to boot from USB.

The PC refuses to recognise the Freedombox bootable drive created from the 64-bit x86 (amd64) Freedombox Stable image 2021-08-27. (Also, I get the same result when trying to use a Testing image.)

Has anyone faced a similar issue? I’ve been going around in circles for days trying to troubleshoot what is happening. No luck so far.

Steps to Reproduce

  1. Download freedombox-bullseye-free_all-amd64.img.xz Stable (2021-08-27)
  2. Verify the image as per these instructions (no errors found)
  3. xz -d freedombox-bullseye-free_all-amd64.img.xz
  4. sudo dd bs=1M if=freedombox-bullseye-free_all-amd64.img of=/dev/sdb conv=fdatasync status=progress USB drive appears as \dev\sdb.
  5. When dd has completed (no errors), insert into PC and reboot. Interrupt startup with F12 and choose Select boot device.

Expected Results
I expect to see the USB drive as a bootable option in the Startup menu.

Actual results
The USB drive is not shown on the list of available options.

Information

  • FreedomBox version: Stable 2021-08-27
  • Hardware: Intel NUC6 x86 (amd64)
  • How did you install FreedomBox?: Downloading Stable image 2021-08-27

Next steps
As a Plan B, I can install Debian (which does boot from USB) and install Freedombox as a package later, but would prefer to approach Freedombox as a complete standalone solution and use the Stable image if I can.

Thanks for reading this far, and for your help.

(sorry for my English)
If you want to install FreedomBox on the internal HDD of the Intel NUC, you have to write the image to the internal disk, like this:

  1. Boot the computer from a Live-USB distribution (like Debian Live)
  2. Download and verify FreedomBox image
  3. sudo dd bs=1M if=freedombox-bullseye-free_all-amd64.img of=/dev/sda conv=fdatasync status=progress where /dev/sda is the internal HDD (this removes all the contents of the HDD)
  4. Boot from the internal HDD and continue with the steps in the manual

I have also installed it on an Intel NUC and so far everything is fine.

2 Likes

Taking a guess at why @m632EGx is unable to see the USB disk: the FreedomBox disk image is not UEFI compatible (we will likely change that in the future). Try changing UEFI/BIOS setting to allow “Legacy booting” or “BIOS booting”.

1 Like

As a Plan B, I can install Debian (which does boot from USB) and install Freedombox as a package later, but would prefer to approach Freedombox as a complete standalone solution and use the Stable image if I can.

I used Plan B and it has been flawless (after a bunch of trial and error :slight_smile: )

  • In bios turn off secure boot and make sure that EFI support is enabled.
  • Install Debian with a net-inst image (I used Stable). do not select extra packages, just do the bare minimum. not even ssh.
  • apt update
  • DEBIAN_FRONTEND=noninteractive apt-get install freedombox -y
  • take a photo of your first-boot freedombox key
  • comment out your network interface in /etc/network/interfaces (this will give FreedomBox control of the network interface via NetworkManager)
  • I can’t remember the order of the next steps
    – reboot
    – log in and enter the freedombox first-boot key
    – you should see a welcome message with your FreedomBox web address if you log in via the console or a terminal.

From this point you can do all of your setup and system administration using the FreedomBox web interface.

1 Like

Thanks, @apraile. And your English is excellent :slight_smile:

Your instructions were very clear and this is exactly what I did! I booted from Debian Live and used dd to copy the Freedombox image to the internal SSD of the NUC. I rebooted it and Freedombox installed fine.

I have a couple of problems though, but I will describe these in a new thread.

You are right, @sunil. I needed to make a BIOS change to allow legacy booting.

Also, I had a completely wrong mental model about how Freedombox would be installed on the internal SSD of the PC. I thought the USB drive contained an “installer” which I could point at the SSD, but of course Freedombox is designed/intended (mainly) for single board computers that boot from micro SD cards. Thus my PC was booting from the USB drive.

It’s such an obvious thing, but it took me some time to work out what was happening! :man_facepalming:

I actually adopted the solution that @apraile suggested: use dd to copy the Freedombox image to the internal drive of the PC, then reboot. It seems to have worked fine, but with a couple of problems I’ve noted in another message of this thread.

Thanks for explaining the need to enable Legacy boot on a UEFI machine.

I tried this solution, @joseph but had unresolved network errors that I could not satisfactorily solve. The network service would not come up, and having devoted several hours trying to solve it, I gave up and copied the Freedombox image to the internal drive of the PC instead. It’s now working (mostly). :slight_smile:

Thanks for your detailed instructions.