Wireguard for the raspberry pi?

Hello all, Wireguard is available on freedomBox but not on the raspberry pi 3. My Open VPN instance is nice and has been running solid for approximately a year, but I’d like to try Wireguard. I haven’t bothered to figure out how to send my DNS queries over open VPN. I don’t know if Wireguard does this by default, but I’d still like to try it out. Is there any future plans for Wireguard being released on the Raspberry pi 3?

Wireguard is available in latest debian distributions for testing/unstable (this page in wiki has good explanation debian wiki - wireguard page. Probably the freedombox version you are running is based on an older/stable debian version. That means that the issue of wireguard package being unavailable is irrelevant with the hardware!

I am not sure what you mean by ‘send DNS queries over VPN’. OpenVPN setup as it is at the moment in Freedombox is setting as default gateway your VPN server (freedobox that is). That means that all your traffic (including your DNS queries) are sent over the VPN server.

Hope this answers your question.

1 Like

Thanks for the info! I’ll update my freedom Box then. My VPN (maybe it’s the client I use) doesn’t though, it’s odd. I use my laptop at work and the office network will still block sites even though I am connected to the VPN (I can see and interact with the things connected to my network at home). This is why I assumed it doesn’t pass DNS queries over the VPN. Odd, I’m going to try Wireguard though and see if that fixes the problem because I am not technically advanced enough to fix the problem, I tried :frowning:.

If you have a linux laptop you can modify the file in /etc/resolv.conf to point to a nameserver like or if you have setup bind in freedombox to point your DNS queries in your freedombox internal ip.
The line you need is:
Of course you should remove the nameserver line it has there. In that case you wont be able to access internal domains in your company though.

The resolver (which nameserver you use) is coming with the DHCP as an option (how you are connecting to the company’s network and getting an IP address). Your company’s name server is sitting in a subnet which has a different route than your default - that s why you dns queries still go there even when on the vpn. So after you connect to the company’s network edit the file mentioned above.

Changing VPN technology doesnt mean you willl change the basics of computer networking though.
So I can guarantee you that wireguard will still use the company’s name server if you dont modify the resolv.conf file.

Again, I hope I m not very comfusing!

1 Like

You are not able to access the Internet over OpenVPN because none of the network interfaces on your FreedomBox device are configured as external.

Excerpt from the wiki:

Browsing Internet after connecting to VPN

After connecting to the VPN, the client device will be able to browse the Internet without any further configuration. However, a pre-condition for this to work is that you need to have at least one Internet connected network interface which is part of the ‘External’ firewall zone. Use the networks configuration page to edit the firewall zone for the device’s network interfaces.



I have just updated to 20.3. After pressing check again there is no luck. I use Windows 10 so that should reveal my technical level when it comes to configuring :confused: Ill try to fix the DNS problem later but getting Wiregaurd to work has a higher priority.

njoseph, My OpenVPN works just fine. I can connect to my home network and browse the internet using the VPN no problem. I even use VNC to connect to my machines on my home network.

For modifying Windows DNS this article looks like helpful https://www.windowscentral.com/how-change-your-pcs-dns-settings-wind

Wireguard is still not available because it has nothing to do with FreedomBox version. It has to do with the Debian version.