What's the secret to get Privoxy working?

Hi, I’ve Installed Privoxy, ran diagnostics and everything is good. Went into the Privoxy config and enabled my freedombox IP. Restarted Privoxy a few times. Tried connecting many times, but no worky.

Any tips?

Personally, I didn’t do this part:

I don’t believe it is necessary but I could be wrong.

Did you configure your browser to use Privoxy as an HTTP/HTTPS proxy?

In Firefox that would be under settings. Search for “Proxy”. Then point to your FB’s IP at port 8118.

I appreciate your response. Yes, I’ve configured two separate browsers but no response from the server. I can reach the FB and have other stuff running on it just fine. So the only thing not working is Privoxy.

I tried removing and reinstalling Privoxy and it appears that the Proxy is refusing the connection still.

From the terminal I checked the status and it’s active. I stopped and started it, tried again and still connections are being refused.

It appears to be allowing internal traffic (which is what I’m trying to do). Not doing anything super-complicated here.

Checking /var/log/privoxy doesn’t seem to show anything. Archived logs are zipped up. How can I read those?

Is there a way to shut the firewall off just for Privoxy somehow? The firewall on my desktop linux client is disabled btw. Anyway, what a total joke this is. It’s just something simple that should work, but it’s been a fight every step of the way. :frowning: Feels like a SlaveBox at the moment. I don’t feel Free at all.

Which browsers did you configure? Chromium-based browser will only work if you set the http_proxy and https_proxy variables first.

Firefox-based browsers can be configured in the settings page.

I apologise if this seems obvious, but I’m just trying to cover all bases.

Have you configured it this way?

I appreciate your help on this.

Just trying this again now to be sure I didn’t miss some detail…so here is my Firefox proxy settings:

Apply > OK settings, and here is the result trying about 3 different websites, including the FB on my LAN:

I don’t use Privoxy but I installed it just to try if I can get it to work. So: I drove it with some effort. I set up Firefox browser. In order to work, the network connection must be set to Internal. The browser configuration is as stated in the above post by fefekrzr. And to enter the settings I had to type http://p.p instead of https://p.p because that is my browser setting and I didn’t bother to change it. Pay attention if you have HTTPS Everywhere addon. Hope I have been helpful. Good luck!

1 Like

Thanks for the detail about the Internal connection. It was set to External, so I changed it to Internal. Unfortunately, this resulted in the privoxy service not being able to start at all, and it presumably broke some other stuff too, so I changed it back.

*Edit: Initially I thought I just had to restart the privoxy service after changing the interface to use Internal, however the service simply would not start after that.

Do I possibly need to just restart the entire FB after changing the network interface to Internal?

No, you don’t need to restart either the whole fb or the app itself. I personally changed the zones several times to make sure they were the problem, without having to restart anything.

Yeah, still not working for me.

The only thing I’m doing different that may be the cause somehow is that this FB instance is a VM running on Proxmox. I disabled the firewall soon after installation. All other services/apps running on this thing work fine though.

IDK, maybe I will try using I2P instead since Privoxy seems to be broken on my FB.

Your browser settings are correct.
As @johnny mentioned, I too believe that you’ll need to have at least one network interface in the internal zone.

I’m a bit intrigued by this still:

What did you mean by it? Where did you “enable your FreedomBox IP”? As far as I know, this step is not necessary. I’ve reinstalled by FreedomBox several times; I have always installed and used Privoxy; I have never changed my default config. My Privoxy instance works perfectly.

I’m hoping that you just changed something in the Privoxy configuration that caused it not to work. As a last resort you could uninstall and reinstall Privoxy and try the default configuration.

Another possible issue could be related to networking with a VM. Are you contacting your other services locally (with FB’s local IP address or local domain) or through the outward-pointing domain name?

This problem seems strange, I feel we are missing some information here…

Sidenote: I believe I2P is not available in the Debian repositories at the moment. If you haven’t installed it yet, you will not be able to. If you already did install it, I’d advise to research about why it was taken down. I skimmed through some posts and, if I recall correctly, there was some security issue that needed to be fixed. Something about de-anonymizing eepsites. I don’t use I2P right now, so I might be wrong. I just wanted to give you a heads up.

Privoxy didn’t work out of the box, so I did a nano into the config and uncommented the listen address and changed it to locahost:8118 (also tried, and tried the local ip:8118). That is what I mean when I said ‘enable’ the FB IP.

I just went back into the config and commented out the changes I made, restarted Privoxy, tried again. Still not working.

I have since tried uninstalling and reinstalling privoxy. Apparently uninstalling is an ‘experimental feature’ with Freedombox according to what I was shown from the GUI when I did an uninstall. Still not working.

Yes, I have a Matrix server on the FB that’s been working for over a year. I also have been using Calibre, and BePasty with no problems. Everything is working fine. Privoxy seems broken for me. :frowning:

OK. It’s a shame it didn’t work. But this leads me to believe that it might be a networking problem with the VM.

I apologize for any questions that seem obvious. Please, bear with me.

You wrote this:

I can’t be certain, but I’d imagine that these services are being accessed from the internet through the FreedomBox’s domain name (eg: https://freedombox.rocks) and not the local IP or local name (freedombox.local).

Since you are trying to access Privoxy from within a LAN, I reckon that the VM’s network interface must be configured to be in Bridged mode (or Bridged Adapter) and not NAT. Is this the case with your VM?

What is the network adapter of the virtual machine set to?

Edit: Before writing this suggestion about the VM’s network adapter, I forgot to ask if you were able to access Plinth through the FreedomBox’s local ip address. If you can, then disregard my message. Sorry.

For what it’s worth, here is what my network config looks like in ProxMox:

I just tried unticking Firewall, rebooted the FB, but still no worky. :frowning:

I suppose I could try running Privoxy in a VM. There doesn’t seem to be any LXC’s available for it, So I could install Debian server and install Privoxy and see if that works.

Egh, I really hoped the network adapter was the problem. I’m running out of ideas here. Maybe someone else can come up with another solution to try.

It is a shame, as on my Pioneer, I’d say Privoxy is one of the easiest services to get going.

I definitely believe you and it should be simple enough. I think I will try running Privoxy on a Debian server instance just as a troubleshooting step if for anything else.

Frankie, you inspired me to have another go at this. My own struggle is to get privoxy running through SwitchyOmega proxy switching extension.

  1. if you are using a proxy extension in your browser disable that and configure the proxy in the OS or browser level. See if that works by checking http://p.p

  2. if not working yet, try this proxy configuration:

Here’s what Privoxy says about this…
I haven’t modified any privoxy configuration and it appears that https-inspection is off by default.

#2 worked for me just now. Here’s the relevant quote

  • Hint: Most of the time the protocol should be HTTP or SOCKS/SOCKS5. HTTPS proxies are pretty rare.

HTTP + SOCKS5 didn’t work for me, but HTTP only did.

#3 go back to your proxy extension if you’re using one and try the HTTP only configuration without setting HTTPS proxy. Don’t forget to undo the OS proxy when you switch back to the proxy extension.


Here are my results ( privoxy + brave + ublock origin + privacy badger + local CDN + redirect AMP to html + a newly folded tinfoil hat )