Unable to SSH into admin account

Hi there,

I can’t SSH into my FreedomBox’s admin account. When I try, I get the ‘Permission denied, please try again’ error.
I know I am typing the password correctly, because I am able to login into the admin user’s account via Plinth, both over the clearnet and Tor. However, I’m unable to access Cockpit. It crashes and sends the error to journal.ctl, which I have no current way to read.

I tried all of these options to SSH into the box:

admin@[local IP address]
admin@[domain name]
admin@[.onion address]

I have tried the ssh command by itself, as well as ‘sudo ssh’ and there is no difference.

All give me the same result, except the .onion address, which tells me the name or service is unknown. The FreedomBox and I are on the same local network.
A different FreedomBox I manage, which is not on the same network as I am, gives me no problem whatsoever for SSH.

I double-checked the port forwarding, and port 22 is enabled. I’m not sure what’s going on. Any ideas?

FreedomBox Connection type: plugged into router
FreedomBox Version: latest stable

Are you using a keyboard layout that is not default US layout? I sometimes have the problem that my keyboard (not US) is set to US in some window and I don’t notice when I type a password because I can’t see the characters.

Since you can login to plinth, you could try adding a public key (cleck on your admin user name when logged in and “modify”) and see if that works.

Otherwise, did you ever login via ssh before and change some things, like file/dir permissions in the home dir of admin user?