Unable to log in to plinth

Problem Description
Clicking on the log in link on the web interface results in:

Requested page /plinth/accounts/login/locked/ was not found.

This is new. I used to be able to log in but haven’t tried via the web interface in a while. SSH login works fine. Services appear to be operating correctly. The only message in the system log is:

Not Found: /plinth/accounts/login/locked/

Steps to Reproduce

  1. Open the freedombox.lan page in Firefox 95.01.
  2. Click the Log In link. The browser opens https://freedombox.lan/plinth/accounts/login/locked/?username= and displays the 404 error message. Appending any valid username to the URL - same result.

Expected Results
I should be able to log in.

Actual results
I am unable to log in via the web interface for any account.



  • Linux freedombox 5.10.0-10-amd64 #1 SMP Debian 5.10.84-1 (2021-12-08) x86_64

Have you tried using .local (instead of .lan)? I have no clue if it would make a difference, just that’s how I’ve always typed it in.

I can confirm that this URL is 404.
Could you please try going to /plinth/locked/ instead, and see if you can login with captcha there?

Thank you, James! I was able to log in via that URL and I immediately got a notification that a distribution update was started. Do updates require a regular web login?

Was this a browser cache issue? I thought I tried clearing the browser cache.

Updates are automatic by default, so they could start without anyone logged in.

No, the original issue is reproducible regardless of browser cache.

There is a fix available for this issue. It will be released soon.

1 Like