Unable to access cockpit on Pi 3B

Problem Description
I’m attempting to access cockpit, but get an error stating “connection failed”. I have confirmed that the hostname is reachable via DNS from other devices on the LAN, both with and without the domain name.

Steps to Reproduce

  1. Access freedombox using my domain
  2. Login to freedombox
  3. Click Cockpit
  4. Log in using valid credentials
  5. Receive error

Expected Results
I log into Cockpit.

Actual results
I get the following error: " Connection failed! There was an unexpected error while connecting to the machine. Messages related to the failure might be found in the journal: journalctl -u cockpit > (Updating configuration failed: error reading configuration file.)"

Journalctl -u cockpit returns the following:

root@freedombox:/home/user# journalctl -u cockpit
– Journal begins at Tue 2021-07-13 17:29:26 UTC, ends at Mon 2022-03-28 23:32:55 UTC. –
Mar 28 23:26:26 freedombox systemd[1]: Starting Cockpit Web Service…
Mar 28 23:26:28 freedombox systemd[1]: Started Cockpit Web Service.
Mar 28 23:28:04 freedombox systemd[1]: cockpit.service: Succeeded.
Mar 28 23:28:04 freedombox systemd[1]: cockpit.service: Consumed 1.303s CPU time.
Mar 28 23:30:00 freedombox systemd[1]: Starting Cockpit Web Service…
Mar 28 23:30:00 freedombox systemd[1]: Started Cockpit Web Service.
Mar 28 23:31:39 freedombox systemd[1]: cockpit.service: Succeeded.



  • FreedomBox version: 22.7
  • Hardware: Raspberry Pi 3B
  • How did you install FreedomBox?: Downloaded Pi 3B image from freedombox.org. I have re-downloaded the image three times, installing it onto a new SD card each time.

@UrgencyWelcomeCat Welcome to the forum!
It looks like Cockpit didn’t redirect properly to its secured web version. Please make sure that you access your domain with the https:// prefix like: https://freedombox.floor9.com/_cockpit/

Thanks. I added the cert as a trusted CA, but am still getting the same error.

Please try to follow my relevant replies under this post:

Let me know if it works!

Thanks. I created an entry for the FQDN in \windows\system32\drivers\etc\hosts and confirmed the IP resolves correctly. I’m still able to access freedombox using the FQDN, but Cockpit continues to return the same error.

I added an A zone to my public DNS records for my domain, pointing at my public IP. This step shouldn’t have any impact since freedombox won’t be accessible from the internet, but I wanted to rule out the possibility that some internal process was attempting a third-party DNS lookup (such as a hard-coded reference to and barfing. Seems unlikely, but it’s an easy box to check.

I purged my DNS cache (ipconfig /flushdns) and tested again. Ping correctly resolves the FQDN to my local IP. External nslookups correctly resolve the FQDN to my public IP. Cockpit is still inaccessible.

I then updated my freedombox’s domain name to “local” (system > configure > domain name). I added a new exception for https://freedombox.local in Firefox. Cockpit is now accessible. Using the wrong FQDN is an acceptable workaround but I’d prefer to use my own domain name.