TT-RSS, Server OK can't access from F-Droid App?


I installed TT-RSS via FreedomBox. Via my browser, everything is working AOK. I have a freedombox user assigned TT-RSS, and can login from the URL with that account to get to the TT-RSS interface.

However, when I download the TT-RSS reader via F-Droid, I can not get the app to connect to the server.

My app settings I’m using:
(have also tried without the tt-rss, with /plinth/ with tt-ss/public.php - none were working).
Username: my username
Password: my password

There are also app options for 'HTTP Authentication settings. I tried using the above username and password in thsi input field as well but it did not work.

Which username/password input ‘should’ I be using? The inputs under the connection preferences or the inputs under ‘HTTP-Authentication Settings’ input?

SSL: I unchecked Google Play Services, I checked accept all SSL certs and Trust all Hosts. My Freedombox has a cert active created with Lets encrypt.

From the log file in the app, it is sometimes saying a 307 re-direct caused an issue. That’s why I was trying different permutations of the URL.

And I’ve also seen it generate a certificate error in the log. So I checked the accept all SSL.

Do you have any ideas what my next options could be?

Hi, you should follow the instructions in the FreedomBox manual.