Transmission torrents never go away (probably solved)

Torrents in transmission can’t be deleted

Torrents in transmission never really go away, and will self-populate after a restart of Freedombox or transmission app.

How to replicate
Add a torrent to Transmission. Download it.
Delete the torrent (right click, and select “delete torrent with data”)
At this point the data is deleted from storage and the torrent left the list.
Restart transmission (in freedombox/plinth/apps by toggling the app, or by restarting the whole freedombox)
Check transmission - the torrent has returned, and probably started downloading again.

Proposed Solution
Set defaults so deleted torrents stay deleted.

I cannot reproduce this issue on my FreedomBox (Pioneer edition).

1 Like

If freedombox is running from an sdcard, data can likely become read-only internally after errors.

1 Like

That means, things still seem to work because the kernel buffers writes in ram, but changes never end up on the flash.

1 Like

@strictdual , also have you used the system snapshot restore feature?

1 Like

I have not tried the snapshot restore feature.

If others are reporting that it works properly, it is probably due to my unusual install.

I have raspberry Pi4, with Freedombox installed using apt, on top of raspberry pi os.

going to try to get the official images for the Pi4 to work.