Syncthing doesn't sync folder with Android

  • FreedomBox plugged into router.
  • Recently bought new kit.
  • Running Debian GNU/Linux 10 (buster) and FreedomBox version 21.4.

Pioneer FreedomBox and Android devices recognized each other successfully.

I attached external storage media to Pioneer FreedomBox. I used SSH to enter into Pioneer FreedomBox, created empty “test” folder (receive only) in external storage media, then created empty “test” folder (send only) in Android. The folders recognized each other.

But when I moved one file into Android “test” folder, Pioneer FreedomBox “test” folder seemed to recognize there’s a file, but does not sync. Pioneer FreedomBox “test” folder says “Out of Sync,” and under “Out of Sync items” lists 1 file of 205 KB (the correct size of the file).

My guess is Pioneer FreedomBox’s Syncthing does not have permission to write to external storage media, but I’m not sure.

Any thoughts?

Hi. If this is the wrong place to ask, could someone please guide me to the correct place?

An update: I changed the permissions of each folder to “Receive & Send”. Then, I created a text file in the “test” folder of the external storage media attached to the Pioneer FreedomBox. The text file appeared in the Android “test” folder, but the files in the Android test folder still have not appeared in the external media’s test folder. This leads me to believe I have the correct paths of each folder, but there’s still some issue about writing to the external storage media.

I’ve been looking online and have found no answers. Could someone please provide support for this product?

An update:

Hello everyone.

I think I may have discovered a solution using chown. See my post at Cannot sync b/w android and storage media - #3 by tag - Support - Syncthing Community Forum

So things seem to be working now, but as I stated in the link above, I’m still confused b/c I tried using chown before and Pioneer FreedomBox said I don’t have permission to chown. I tried again later then chown worked. Any thoughts?

As far as I know, FreedomBox currently doesn’t support storing application data on external disks. This is still being implemented. See this issue