SSH: Remote host Identificatio changed

Hi guys, I am utterly lost now and wonder if anyone would be able to help me get this sorted. I am unable to login via ssh and receive this message.

Someone could be eavesdropping on you right now (man-in-the-middle attack)!
It is also possible that a host key has just been changed.
The fingerprint for the ECDSA key sent by the remote host is
Please contact your system administrator.
Add correct host key in C:\Users\markw/.ssh/known_hosts to get rid of this message.
Offending ECDSA key in C:\Users\markw/.ssh/known_hosts:2
ECDSA host key for freedombox.local has changed and you have requested strict checking.
Host key verification failed.

This could also happen if there was another SSH server earlier on that hostname or IP address.

Go to the web interface and open the SSH application in System section. It will show you the fingerprint of the SSH server running on your FreedomBox. If this fingerprint matches the one you are seeing in the message you have posted (the part after SHA256), then all is good. You can edit the file C:\Users\markw/.ssh/known_hosts on your windows machine and delete the line number 2 and problem will be solved. Do not do this if the fingerprint does not match. In that case, double check that you are connecting to the correct server (IP address or hostname).

1 Like

Bingo, Thanks Sunil it took me a minute but I am in.

On to the next hurdle lol

I am sorry to bother you guys again but now I have managed to login via ssh I do not want to lose the momentum. I have got further today than I have done in 2 years.

I run the apt update and get this after a process runs

We trust you have received the usual lecture from the local System
Administrator. It usually boils down to these three things:

#1) Respect the privacy of others.
#2) Think before you type.
#3) With great power comes great responsibility.

[sudo] password for Mark:
Hit:1 stable InRelease
Get:2 stable-updates InRelease [51.9 kB]
Get:3 buster-backports InRelease [46.7 kB]
Hit:4 stable/updates InRelease
Fetched 98.6 kB in 5s (21.6 kB/s)
Reading package listsā€¦ Done
Building dependency tree
Reading state informationā€¦ Done
4 packages can be upgraded. Run ā€˜apt list --upgradableā€™ to see them.
Mark@freedombox:~$ apt list --upgradable
Listingā€¦ Done
apt-utils/stable-updates armhf [upgradable from:]
apt/stable-updates armhf [upgradable from:]
libapt-inst2.0/stable-updates armhf [upgradable from:]
libapt-pkg5.0/stable-updates armhf [upgradable from:]

There are packages listed but do not know how to go any further. Any help would be greatly appreciated as I do not want to give up on such an important project.

Many thanks

Hello @Arcadian

You have run the command:

sudo apt update

The next one to install the packages is:

sudo apt upgrade

Or you can let Freedombox do the job for you. Go to the System section of your Freedombox and then go to the Update section. There you will see ā€œEnable auto-updateā€ and at the side you will see a check box, if it been checked Freedombox will look after your update and install them for you.

Regards: peter


Many thanks Peter, i think this has done the trick.

There could be problems with running apt update. apt/dpkg could face a configuration file prompt when FreedomBox has modified a configuration file and a newer version of the configuration is shipped by package maintainer. We try to avoid these but that is not always possible. In this case, dpkg will throw technical questions at you about how to merge the configuration.

Instead you can simply enabled automatic software updates in FreedomBox (this is the default). This run updates every day at night (and reboot machine if necessary). If you want to run update immediately without waiting for midnight, then trigger manual update from FreedomBox UI or run unattended-upgrade command on the command line. This way, FreedomBox will intervene on your behalf for the packages that need configuration file upgrade and do the right thing.


Thank you again for your reply.

I had already run the apt upgrade before reading your reply. It does seem to have worked and I can update my apps for the first time.

I am confused however. If I could have done this through the built in auto update why was it necessary to ssh in the first place. I read that due to the date I bought the device it was required because to a bug. Was I wrong to think this?

I have found this entire process very convoluted and hard to follow with no comprehensive tutorials or guids. I have spent ages, years, since buying the box reading the manual, clinking on links trying to find the information I need to further my knowledge but am always left with more questions each time. The manual itself is so bare bones, all it does is describe the use case and description of each app and does not give any information regarding the process of setting the app up correctly or how to use it.

That being said, I feel very strongly that the importance of this project will only grow in coming years. I intend to keep learning and reading and will do anything I can to help this project grow.

1 Like

The problem was due to outdated version of FreedomBox for which the primary solution was just to wait a few days for everything to auto-update. The manual process is only for getting things ready immediately without wait. These workarounds wonā€™t be needed anymore with the new Debian release, of course. Documentation could use improvement. You too can contribute by editing the wiki pages.