[SOLVED] Stuck on 21.4.4

Hi -
Why is my system stuck on 21.4.4?

freedombox is already the newest version (21.4.4).

This is on a fresh debian 11 install / fresh freedombox install.

Do I need to change something in sources.list? :

GNU nano 5.4 sources.list
deb cdrom:[Debian GNU/Linux 11.3.0 Bullseye - Official amd64 NETINST 202203>

deb cdrom:[Debian GNU/Linux 11.3.0 Bullseye - Official amd64 NETINST 2022032>

deb Index of /debian bullseye main
deb-src Index of /debian bullseye main

deb Index of /debian-security bullseye-security main
deb-src Index of /debian-security bullseye-security main

bullseye-updates, to get updates before a point release is made;
see Chapter 2. Debian package management>
deb Index of /debian bullseye-updates main
deb-src Index of /debian bullseye-updates main

This system was installed using small removable media
(e.g. netinst, live or single CD). The matching “deb cdrom”
entries were disabled at the end of the installation process.
For information about how to configure apt package sources,
see the sources.list(5) manual.

Under System/Software Update, do you have Frequent Feature Updates enabled? I think that’s needed to pick up new freedombox versions from bullseye-backports.

thank you for the reply!
yes, I have it all checked:

Please run sudo /usr/share/plinth/actions/upgrades activate-backports, and see if you can update after that.

Ok, did it, and I’m now trying to manually update. Thanks for the idea. I’ll report back when it’s done updating.

ok, the first thing it did was give me this error:

> Error installing application: Error during installation E: Problem renaming the file /var/cache/apt/pkgcache.bin.oWrQYS to /var/cache/apt/pkgcache.bin - rename (2: No such file or directory) W: You may want to run apt-get update to correct these problems E: The package cache file is corrupted Traceback (most recent call last): File "/usr/share/plinth/actions/packages", line 424, in <module> main() File "/usr/share/plinth/actions/packages", line 420, in main subcommand_method(arguments) File "/usr/share/plinth/actions/packages", line 103, in subcommand_install with apt_hold_freedombox(): File "/usr/lib/python3.9/contextlib.py", line 117, in __enter__ return next(self.gen) File "/usr/lib/python3/dist-packages/plinth/action_utils.py", line 442, in apt_hold_freedombox current_hold = subprocess.check_output( File "/usr/lib/python3.9/subprocess.py", line 424, in check_output return run(*popenargs, stdout=PIPE, timeout=timeout, check=True, File "/usr/lib/python3.9/subprocess.py", line 528, in run raise CalledProcessError(retcode, process.args, subprocess.CalledProcessError: Command '['apt-mark', 'showhold', 'freedombox']' returned non-zero exit status 100.

so I did

apt-get update

and tried updating again.

This time, it looks like it worked, but I haven’t seen this version of freedombox:

So… I guess that’s what it needed maybe.

Thanks for all the help, @nbenedek !

1 Like