[SOLVED] Samba share not working, fresh debian install, internal network issue?

Problem Description

I am trying to set up a freedombox as a home server with a samba share. I have installed on a miniPC by first installing debian bookworm then apt installing freedombox on top. Everything seems to be working except for samba. (In particular command line sftp is working to access my share.)

Steps to Reproduce

  1. fresh install debian bookworm onto miniPC
  2. install freedombox onto it using apt-get
  3. in plinth, run samba. share a folder as public
  4. try to connect to the samba share from another local machine. eg. from an ubuntu machine, nautilus->other locations->connect to server-> smb://freedombox.local/disk
  5. press return leaving password request boxes empty

Expected Results
Share should mount in the nautilus viewer

Actual results
error message: Unable to access location. Failed to mount windows share: invalid argument.


  • FreedomBox version: Linux freedombox 6.1.0-3-amd64 #1 SMP PREEMPT_DYNAMIC Debian 6.1.8-1 (2023-01-29) x86_64
  • Hardware: HP mini PC. Wired ethernet connection to home router. DMZ enabled for freedombox.
  • How did you install FreedomBox?: Installed debian bookworm. then apt install freedombox.

I think this may be something to do with freedombox’s settings for internal networks? There was a comment somewhere about network interfaces not managed by freedombox, possibly Debian ‘owns’ my ethernet connection so freedombox isn’t able to consider it as an internal connection?
I tried going to freedombox->system->networks. The only connection listed is ‘lo’ local loopback. Tried adding a new connection linked to my eth card but it will not activate. Tried activating it in the TUI from ssh and got an error saying the connection is unmanaged so cant be activated.
AFAIK the samba server will only accept connections from an “internal” network card but I can’t find any way to make freedombox treat the existing connection – set up in debian before freedombox was added – as internal in order to run samba.

The Samba app shows this message: " Samba is available only on internal networks or when the client is connected to FreedomBox through VPN. Currently there are no network interfaces configured as internal."

I suggest this is quite an an urgent issue, most FB users want to run a samba share and sometimes that’s the only/main use case. And this could affect all users who are running on full size servers that start with debian rather than the single board boxes.

First and second pictures clearly indicate there is no internal network setup.

You need to follow the network setup. Not sure how you ended up without any network connections (its been more than a year since I set mine up) but documentation can walk you through setting it up.

I think this page should get you on track.

EDIT- I’ll append that installing the absolute latest Debian is probably ill-advised. Not sure how much time the FB team has to make adjustments if needed. Rather than Bookworm, I’d do Bullseye and upgrade after the early adopters have vetted it.


Thankyou very much Timmy. I have got it working now by studying those and related instructions.

Details were:

  • All of freedombox networking, cockpit, and the commandline nmtui tools are frontends for Debian’s NetworkManager.
  • NetworkManager only manages connections which are given to it. According to
    NetworkManager - Debian Wiki
    we can check if a connection is given to it by looking at file
    and looking for
  • changing this to true then rebooting did the trick.
  • I could then see the connection appear in FB networking and was able to set it to internal.
  • Samba is now working.

(Possibly the issue was related to another when installing bookworm: the Debian installer was unable to automatically configure the network because my router has an unusual IP, so I had to do it manually in the installer. So maybe that causes the connection to be not managed by NetworkManager.)

1 Like