[SOLVED] Redirection broken after unattended upgrade to 20.18

After the nightly bout of unattended upgrades, I can no longer access the tt-rss app through the web front-end. If I just enter the URL ( ip/tt-rss/ ), then both Firefox and Chrome time out, complaining that “the site is not redirecting correctly” or the equivalent.

There have been literally no other changes to this machine since the previous day, when all worked fine, and this happens regardless of whether I attempt to open the site by hostname, IPv4 address, or IPv6 address. It happens in Chrom(ium) and in Firefox. Firefox’s debugger at least records an indication of what is breaking

As in this screenshot, the tt-rss URI gets redirected to the SSO page, which then fails to redirect back to tt-rss. Yes, I am signed in. I have also tried it by signing out and then signing in afresh. I have tried it in private mode and with a fresh Firefox profile. I have restarted the tt-rss service, and I have rebooted the machine. None of those makes a difference to the outcome.

(additional detail: I was able to verify that tt-rss dos still work through the -api endpoint as used by the Android app. So tt-rss itself does not seem to be broken, based just on this evidence.)

The upgrade log says that the 11/26 upgrade was freedombox (20.18~bpo10+1) over (20.17~bpo10+1). It doesn’t report errors having occurred.

The only thing I have found in any of the error logs that might be somewhat related is a lot of Apache2 [:warn]-level errors of the form TKT parse_ticket missing keys in ticket 'uid', referer: https://[THE_FREEDOMBOX_ADDRESS]/tt-rss/index.php

Again, nothing else changed at all since yesterday when this was functional, so it appears to be server-side, not a browser problem, and it seemingly started only after this 20.18 upgrade.


I have the same problem.

I ran a manual update that picked up new version 20.18.1, which resolved the problem for me. Everyone’s next unattended upgrade should pick up 20.18.1 if it hasn’t already been installed manually.

I’m currently having what is (I’m sure) a related issue, when trying to navigate to the Searx page on my FB, I get a nearly blank page, that says redirection broken.

Follow Up: Upgrading to version 20.18.1 appears to have fixed the issue, I can now use my Searx again.