[Solved] Radicale not syncing new contacts created on client

I’ve just migrated my contact list into Radicale in FreedomBox 20.12.1 running on a Raspberry Pi 3 / Debian Duster. All is good so far except that syncing contacts from client to server does not seem to be working.

My client is Thunderbird/Cardbook 68.12.0 (64-bit) / Manjaro Linux. I can see all the contacts on the server and syncing appeared to be working fine. However, when I created a new contact on the client, syncing returned the following result (shown in the bottom status bar of Thunderbird):

Number of contacts: 516 (locally modified: 1)

The locally-modified contact is the problem. It stays as locally modified, regardless of how often I sync with the server. Furthermore, the new contact does not get synced with the server and remains unknown to all other clients.

Login details to FreedomBox are fine, and there are no other warnings of any obvious problem.

Can anyone shed some light on why this might be happening and what I can try to solve it?


There are not recent changes to Radicale or its management in FreedomBox.

  • It is worth checking if other clients are able to push their changes to FreedomBox. If they are, the Cardbook addon could be misbehaving. I use the TbSync addon along with TbSync CardDAV/CalDAV addon (I remember facing issues with Cardbook).
  • Another possibility is that your SD card ran into HW issues and the file system is in read-only mode. Are you able to write anything to the disk? You can check using a terminal or by trying to upload a file (through shares, torrents, etc.).

Thanks, @sunil. My Android Contacts client (and Calendar client) failed to push new records to FreedomBox (using DAVx5 CalDAV/CardDAV sync adapter). SD card is not read-only because I could create a new text file in ~/ after logging in with SSH.

My previous server was using Nextcloud for contacts and calendar (hosted service) and it’s worked fine for years with the same clients (Thunderbird/Lightning/Cardbook).

I’ve not done anything unusual with Radicale: just installed the App as usual and set up Addressbook and Calendar using the Radicale interface. It all looks fine, except that I cannot write new contact records :frowning:

[Edit: calendar sync problem was a false alarm. Calendar is working fine.]

[Second Edit: Solved. My fault. I had recently changed the FreedomBox domain name but did not update all my client settings. Created new addressbook in Cardbook with correct URL for Radicale server and to/from syncing now works.]

Thanks, @sunil and sorry for the false alarm.