[SOLVED] Problems with install of rolling distro on RPi 3B+

#1

I have twice downloaded and verified the system image from your download page, and flashed it to two different 8gb SD cards. I have tried to boot a half dozen times with each on 2 different RPi 3B+ and it goes through initial steps of boot, loads kernel, gives me a few cycling underscores on monitor, then it stops sending video to monitor. Is this install made to be run headless exclusively? Is there not a way to go through initial set up and config using an attached monitor? What could possibly be wrong with my methods/install? Please let me know, as I am very interested in your product and would like to buy 2 or more, but I must first confirm it works for my needs on a SBC before pulling the trigger on the purchase. Thank you.

#2

What you’re seeing is expected behavior according to the wiki.

Please do not expect any output on a monitor connected via HDMI to this device as it does not display anything beyond the message ‘Starting kernel…’. See the Quick Start page to access and control your FreedomBox from network.

https://wiki.debian.org/FreedomBox/Hardware/RaspberryPi3B+

If you have only one FreedomBox on your local network, you can reach it by typing freedombox.local in your browser. Otherwise, use the corresponding IP address of the devices.

FreedomBox is meant to be accessed using the web application through a browser (and an Android app, still in early stages of development). Things like HDMI, audio/video etc. are not required for a personal server operating system. FreedomBox images might not ship with the necessary drivers, especially if they’re non-free.

Please follow the video tutorial on the homepage of freedombox.org which shows installation on a Raspberry Pi.

#3

On Raspberry Pi 3B+ it is confirmed that display shows nothing beyond “Starting kernel…”. This is because the upstream kernel doesn’t support the display on HDMI for Raspberry Pi. When this support gets added the support will come into Debian and FreedomBox images.

#4

Thank you for your response. I have now tried multiple times to boot the Pi headless, connected to my router with an Ethernet cable, as directed in the video on your main page with no luck. The Ethernet connection lights never come on, even an hour after initial boot, with a known good Pi3B+ from my gaming set up, and a brand new 3B+, fresh out of the box. I have tried 8 and 32 gb cards with images that were downloaded and verified using your methods. The unzipped images are 3.98 gb, I am guessing they are supposed to be that big as they verified, even though your 2017 era video states a smaller unzipped size. Any thoughts on what could be wrong at this point?
Thanks again in advance, Drew

#5

njoseph- Thank you for your response, I had skipped over the install video, and just dug through the install wiki, never seeing reference to the monitor not being supported after kernel loaded.

#6

I am stupid, solved
the ethernet cable I was using was no good. All is well, installing apps as I type here, sorry to bother you.

#7

No problem. I was starting to suspect the cable as well since I think Ethernet lights start blinking as soon as power on happens even before the OS starts up.

1 Like
#8

I just installed it on the router and browsed to https://freedombox.local . I was then able to configure everything.