[SOLVED] Problems with Cockpit & Javascript Restrictor

This is the second time I am having these problems, the last time it happened it was solved on the next day without doing anything.

What happens: I can log in to cockpit, the overview page is displayed with the four sections “Health”, “Usage”, “System information”, “Configuration” (might not be the exact names in English as I am translating from French), but Health is empty, CPU is 0, memory is zero, no ID, no on time, only system time is shown.

“Journal”, “Storage”, “Network”, “Services” show “loading” with a wheel forever. “Accounts” shows a blank page, “Applications” a smaller wheel forever, “Software updates” shows “Checking software status” and “Loading available updates, please wait” with a wheel forever.

“sudo systemctl restart cockpit” does not change anything .

Some pointers:

  • Ensure that you are accessing Cockpit with a valid URL (as listed in the app) and not an IP address.
  • Check browser developer tools to see if any network requests are failing.
  • Check system logs using journalctl -f while accessing Cockpit.
  • Cockpit seems to have services other than cockpit.service. Try restarting them all or reboot the machine.

Probably unrelated since your first incident cleared up spontaneously, but I had the same cockpit symptoms recently after installing the Javascript Restrictor browser extension. Setting the level to 0 (turn wrappers off) in the extension for the domain of my FreedomBox allowed cockpit to function again.

1 Like

This is probably it, you saved me a lot of time, thanks !

I was using my laptop when I saw the problem today, now using my desktop that has the level to 0 and cockpit is fine on it. I can’t check what was on my laptop because I made something wrong on it and it is no more booting, will fix that later.

1 Like