SOLVED: Problem installing infinoted on fbx v0.13.1: diagnostics fail

#1

I tried installing infinoted in plinth today. When the install finished I was presented the Status message “Service Gobby Server (infinoted) is not running” followed by the “Run Diagnostics” button. Clicking that button I am told that module infinoted test “listening on port 6523” failed for both ipv4 and ipv6

/var/log/syslog has this in it:

infinoted[11615]: Failed to open file '/etc/infinoted/iinfinoted-key.pem': Permission denied
systemd[1]: infinoted.service: Main process exited, code=exited, status=255/n/a
systemd[1]: infinoted.service: Unit entered failed state.
systemd[1]: infinoted.service: Failed with result 'exit-code'.

The ownership on the directory /etc/infinoted is infinoted:infinoted and the permissions are 750. The two pem files in the directory are ownership root:root and permissions 640 or in other words:

$ ls -ld /etc/infinoted
drwxr-x--- 2 infinoted infinoted 4096 May  9 15:06 /etc/infinoted/ 

$ sudo ls -l /etc/infinoted
-rw-r----- 1 root root 1724 May  9 15:06 infinoted-cert.pem
-rw-r----- 1 root root 3243 May  9 15:06 infinoted-key.pem

Does anyone recognize this problem? Can anyone help me diagnose?

Information

  • Debian version: 9.9 stretch
  • FreedomBox version: plinth version 0.13.1
  • Hardware: Sheevaplug
  • How did you install FreedomBox?: I followed the instructions for Sheevaplugs on cyrius.com to install debian 9 to an SD card, then ‘apt install freedombox-setup’
#2

The two .pem files should be owned by infinoted:infinoted. It sounds similar to this issue:

1 Like
#3

@jvalleroy, Not just similar, it was exactly that issue. My first attempt to install infinoted ended with the same big hairy error message that started the post in the link you gave.

As in that post the fix was to become root with

$ sudo su -

and to change the ownership of the two *.pem files with

# chown infinoted:infinoted /etc/infinoted/infinoted-*.pem
# exit
$ sudo -k

Thanks for your help

#4

This issue is not reproducible on FreedomBox 19.2 as tested on https://demo.freedombox.org