[SOLVED] Privoxy and Diagnostics

#1

Hi All,

Privoxy is not working, I have followed all the instructions.

I ran Diagnostics and the followig tests have ‘failed’ :

  • Listening on tcp6 port 8000

  • Access URL http://[fe80::2f94:34d0:864f:808a%enxb827ebadfa52]/plinth/ on tcp6

  • Using DNSSEC on IPv4

  • Using DNSSEC on IPv6

If this is the reason for Privoxy not working then how do I resolve these issues?

#2

Hi All,

I suppose that the Freedombox has been thoroughly tested and that there is nothing wrong with it! That is my first assumption. So what’s wrong?

User error? Of course!

For those of you who use Qubes OS, the solution is to run the VM that accesses the Freedombox straight to sys-net bypassing the Firewall.

Magic!

When I run Diagnostics, I still get all these ‘failed’ test results. Any ideas how to resolve these?

2 Likes
#3

what SBC are you using. It worked for me out of the box with a raspberry PI 3B+ Got all green in diagonstics

#4

Good to know that issue is now resolved. Thanks for providing the information for Qubes OS users.

These have been failing for a while. They are more of a TODO item for us fix :slight_smile: and don’t result and any loss of functionality currently.

We don’t have DNSSEC properly implemented. So ignore these as well.

The above failures are from general diagnostics. For Privoxy specific diagnostics, just run diagnostics from the app page. They should all be passing.

1 Like
#5

I am using the same, a raspberry PI 3B+.