[SOLVED] Pi 3 B will not reboot - SSD

Hello All and thanks,

The install image was:

That been dd on to a SSD:

Debian GNU/Linux 11 (bullseye) and FreedomBox version 22.21.1

To boot from the USB I have installed the Pi OS 64bit on to the micro card. Booted the Pi from the micro card. Then edited the file shown below with the command:
echo program_usb_boot_mode=1 | sudo tee -a /boot/config.txt

Then I have rebooted and check to see if the USB boot mode as been enabled with the command shown below:

vcgencmd otp_dump | grep 17:

After this check, I remove the micro card and then can boot from the SSD.

The problem is that the Debian install for some reason will not reboot. It will go down but will not come back up.

So any idea why ?

Regards: peter

Hello all,

The Raspberry pi 3 now reboot with the ssd drive. I have just got a Sabrent USB 3.0 to SSD / 2.5-Inch SATA I/II/III Hard Drive Adapter (EC-SSHD) and all is now well. This Sabrent adapter as sorted out the problem of the Raspberry pi 3 not rebooting.

Regards: peter

So this issue is [SOLVED] but I can not edit the title !