[SOLVED] "Package freedombox is marked to be held back"

  • FBX is plugged into a router at home.

  • bought June 2020

  • Version 22.22.1

My FBX doesn’t update anymore, is stuck at the mentioned version.
In the last update logs I found this:

“Package freedombox is marked to be held back”

I guess it has something to do with apt?

I have basic knowledge of Linux and can use the terminal but am by no means an expert. So I’m looking for help to correct this situation.

A big thanks in advance!


After some investigation I found the command “apt-mark”.

Connected to FBX by ssh as admin and issued apt-mark showhold:

**********@freedombox:~$ apt-mark showhold

Would it be possible and safe!! to do “apt-mark unhold freedombox” and afterwards perform a manual upgrade in plinth > system > upgrades?

Since I don’t have a clue why the package is being kept back I’m not sure whether this procedure is a good idea.

The hold mark could be left over when an upgrade operation fails midway. If there are no apt operations pending. You can remove the mark safely. After this you can run upgrades manually.

1 Like

Thanks for your answer @sunil .

Update went well. FBX is now at version 23.6.1.

What really gave me a hard time was finding out the FBX administrator doesn’t have the privileges for performing tasks with apt.
I know the commands “sudo” and “su” but it took me quite a while searching the docs to realize I had to combine these two in order to become root. Very puzzling for me, I still don’t grasp the underlying concepts.
But the documentation helped me find my way, so thanks for this as well!


Edit: How can I mark this topic as solved? I can’t seem to find this option.

1 Like