[SOLVED] No connections possible after restart

I have a new freedombox (Pioneer kit). I have mostly only installed/configured the prepackaged stuff and has been working fine. After a system restart via the web UI, freedombox cannot be reached via web ui or ssh over the local network, via any address ( 10.10.10.101 , where I can see the network knows it is, or freedombox.local , etc). For ssh, I get “ssh: Could not resolve hostname freedombox.local: Name or service not known”. Hard reboots do not solve this. The only thing I’ve done other than install standard packages via the web UI is run apt update && apt upgrade -y . I am not a complete Linux n00b but since I’ve never had a Linux server in the room with me, I think there’s always been someone else dealing with it not coming back online heh. The device is properly connected and had been working fine immediately prior to restart.

I can now add that when connecting a keyboard & monitor to Freedombox, I am able to login as my local user. If I run the prompted systemctrl command to “activate the web console”, I get an authentication prompt at org.freedombox.systemd1.manage-unit-files.

@badom Just a note, “activate the web console” refers to Cockpit, not to the FreedomBox web interface. And the command listed is not correct for enabling Cockpit on FreedomBox.

If you run “ip a s”, do you see an (inet) IP address listed under eth0?

I see inet 10.10.10.101/24 brd 10.10.10.255 scope global dynamic noprefixroute,

You probably getting the authentication prompt because you are not root user. You can use sudo su - to login as root and then run systemctland other commands.

It would be nice if you could check the following:

Checking for network connectivity (assuming 10.10.10.1 is your router’s IP address)

$ ping 10.10.10.1
$ ping 1.1.1.1

On a machine that is not FreedomBox but in the same network:

$ ping 10.10.10.101

On FreedomBox check that services are running fine:

$ systemctl status firewalld
$ ss -nlpt | grep 443
$ ss -nlpt | grep 22

Provide us the output of firewall status (recently there was an upgrade in firewalld package although this should not have affected you):

$ firewall-cmd --list-all-zones

See if disabling firewall works:

$ systemctl stop firewalld

Re-enable after

$ systemctl start firewalld

Verify that firewalld has proper configuration

DefaultZone=external

in /etc/firewalld/firewall.conf.

Check that web server is running

$ systemctl status apache2
$ curl -v http://localhost/

Try this from outside FreedomBox

$ curl -v http://10.10.10.101/
1 Like

Okay, making progress! Thanks Sunil!

Freedombox cannot be pinged from elsewhere on the network.

I can ping outside connections from Freedombox.

$ systemctl status firewalld

Disabling firewall works! I can ping and reach Plinth from remote with firewall disabled.

Restarting firewall gets me back to the original problem.

Verified DefaultZone=external.

Apache2 is running, localhost is running (headers returned), but no connections to Freedombox from outside.

It appears that you facing a bug that was fixed. However, we had issues with making the fixes available to stable release users. We hope that these fixes will be available soon. Meanwhile, you can run the following commands to fix the issue.

firewall-cmd --zone=internal --remove-interface=tun+ --permanent
firewall-cmd --zone=internal --remove-interface=tun+
systemctl restart firewalld
(probably restart the machine here)
firewall-cmd --zone=internal --add-interface=tun0 --permanent
firewall-cmd --zone=internal --add-interface=tun0
1 Like

Awesome! This worked. I did have to restart firewalld one more time at the end, but hooray!

1 Like

We also have freedombox 19.13 on it’s way to all users. It would have fixed the problem too :slight_smile: Thanks for reporting back.